summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFrançois Boulogne2018-04-06 08:46:57 +0200
committerFrançois Boulogne2018-04-06 08:46:57 +0200
commitcee257f4e753cf7ff08bdd3f46d0ee412a1a10b9 (patch)
tree83bb9aacfaf88d517e1f3ea6e73736f121fd5139
parente8cf08f8994060540a9ede4ae5c47fb8e961f74d (diff)
downloadaur-cee257f4e753cf7ff08bdd3f46d0ee412a1a10b9.tar.gz
update to 0.12
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD31
2 files changed, 17 insertions, 27 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b288de027d85..0b3d868f065a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,20 +1,19 @@
# Generated by mksrcinfo v8
-# Sun Jun 5 10:31:55 UTC 2016
+# Fri Apr 6 06:46:31 UTC 2018
pkgbase = ktikz
pkgdesc = A small application helping you to create TikZ diagrams (from the LaTeX pgf package)
- pkgver = 0.10
- pkgrel = 9
+ pkgver = 0.12
+ pkgrel = 1
url = http://www.hackenberger.at/blog/ktikz-editor-for-the-tikz-language/
arch = i686
arch = x86_64
license = GPL
- makedepends = automoc4
makedepends = cmake
makedepends = docbook-xml
- depends = poppler-qt4
+ depends = poppler-qt5
depends = kdebase-runtime
- source = https://launchpad.net/ubuntu/+archive/primary/+files/ktikz_0.10.orig.tar.gz
- md5sums = e8f0826cba2447250bcdcd389a71a2ac
+ source = https://github.com/fhackenberger/ktikz/archive/0.12.tar.gz
+ md5sums = 3834a2c0c7d135eb7f958053a56c07ca
pkgname = ktikz
diff --git a/PKGBUILD b/PKGBUILD
index eb9cec7803fd..90fe53ae0c9e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,30 +1,20 @@
-# $Id: PKGBUILD 172186 2016-04-27 20:47:53Z arojas $
-# Maintainer: Antonio Rojas <arojas@archlinux.org>
-# Contributor: Peter Lewis <plewis@aur.archlinux.org>
-# Contributor: linuxSEAT <--put_my_name_here--@gmail.com>
-# Contributor: Le_J <clej37 at gmail dot com>
-
pkgname=ktikz
-pkgver=0.10
-pkgrel=9
+pkgver=0.12
+pkgrel=1
pkgdesc="A small application helping you to create TikZ diagrams (from the LaTeX pgf package)"
arch=('i686' 'x86_64')
url="http://www.hackenberger.at/blog/ktikz-editor-for-the-tikz-language/"
license=('GPL')
-depends=('poppler-qt4' 'kdebase-runtime')
-makedepends=('automoc4' 'cmake' 'docbook-xml')
-source=("https://launchpad.net/ubuntu/+archive/primary/+files/ktikz_$pkgver.orig.tar.gz")
-md5sums=('e8f0826cba2447250bcdcd389a71a2ac')
-
-prepare() {
-# Fix build
- sed -e 's|\\\\\\||g' -i ktikz/app/CMakeLists.txt
-}
+depends=('poppler-qt5' 'kdebase-runtime')
+makedepends=('cmake' 'docbook-xml')
+source=("https://github.com/fhackenberger/ktikz/archive/$pkgver.tar.gz")
+md5sums=('3834a2c0c7d135eb7f958053a56c07ca')
build() {
- cd $pkgname
-
- cmake -DCMAKE_INSTALL_PREFIX=`kde4-config --prefix`
+ cd $pkgname-$pkgver
+ mkdir buildqt
+ cd buildqt
+ qmake ../qtikz.pro
make
}
@@ -32,3 +22,4 @@ package() {
cd $pkgname
make DESTDIR="$pkgdir" install
}
+