summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAntonio Rojas2016-06-05 12:32:13 +0200
committerAntonio Rojas2016-06-05 12:32:13 +0200
commite8cf08f8994060540a9ede4ae5c47fb8e961f74d (patch)
treec66d76b7cb747130eade07b2ae0ba97410fbc0ef
downloadaur-e8cf08f8994060540a9ede4ae5c47fb8e961f74d.tar.gz
Drop from community
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD34
2 files changed, 54 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b288de027d85
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+# Generated by mksrcinfo v8
+# Sun Jun 5 10:31:55 UTC 2016
+pkgbase = ktikz
+ pkgdesc = A small application helping you to create TikZ diagrams (from the LaTeX pgf package)
+ pkgver = 0.10
+ pkgrel = 9
+ url = http://www.hackenberger.at/blog/ktikz-editor-for-the-tikz-language/
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = automoc4
+ makedepends = cmake
+ makedepends = docbook-xml
+ depends = poppler-qt4
+ depends = kdebase-runtime
+ source = https://launchpad.net/ubuntu/+archive/primary/+files/ktikz_0.10.orig.tar.gz
+ md5sums = e8f0826cba2447250bcdcd389a71a2ac
+
+pkgname = ktikz
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..eb9cec7803fd
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# $Id: PKGBUILD 172186 2016-04-27 20:47:53Z arojas $
+# Maintainer: Antonio Rojas <arojas@archlinux.org>
+# Contributor: Peter Lewis <plewis@aur.archlinux.org>
+# Contributor: linuxSEAT <--put_my_name_here--@gmail.com>
+# Contributor: Le_J <clej37 at gmail dot com>
+
+pkgname=ktikz
+pkgver=0.10
+pkgrel=9
+pkgdesc="A small application helping you to create TikZ diagrams (from the LaTeX pgf package)"
+arch=('i686' 'x86_64')
+url="http://www.hackenberger.at/blog/ktikz-editor-for-the-tikz-language/"
+license=('GPL')
+depends=('poppler-qt4' 'kdebase-runtime')
+makedepends=('automoc4' 'cmake' 'docbook-xml')
+source=("https://launchpad.net/ubuntu/+archive/primary/+files/ktikz_$pkgver.orig.tar.gz")
+md5sums=('e8f0826cba2447250bcdcd389a71a2ac')
+
+prepare() {
+# Fix build
+ sed -e 's|\\\\\\||g' -i ktikz/app/CMakeLists.txt
+}
+
+build() {
+ cd $pkgname
+
+ cmake -DCMAKE_INSTALL_PREFIX=`kde4-config --prefix`
+ make
+}
+
+package() {
+ cd $pkgname
+ make DESTDIR="$pkgdir" install
+}