summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJoão Figueiredo2021-08-30 00:06:13 +0100
committerJoão Figueiredo2021-08-30 00:06:13 +0100
commit5bd135f414fda58c68ad8e3d3d5740da20231154 (patch)
treeae51f3e72fe067d114c2d0247519a23d18bc6c3b
parent47cc3f08ad362c8104260bdfca2179363f496ac2 (diff)
downloadaur-5bd135f414fda58c68ad8e3d3d5740da20231154.tar.gz
Merged with official ABS ktimer PKGBUILD
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD51
2 files changed, 33 insertions, 40 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 120a880d645e..94ee5ae1d3e0 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,24 +1,22 @@
pkgbase = ktimer-git
- pkgdesc = A little tool to execute programs after some time. (GIT version)
- pkgver = 0.10.r264.a3d42f7
+ pkgdesc = Countdown Launcher
+ pkgver = 21.11.70_r468.g08ad6e6
pkgrel = 1
- url = https://www.kde.org/applications/utilities/ktimer
- install = ktimer-git.install
+ url = https://apps.kde.org/ktimer/
arch = x86_64
+ groups = kde-applications-git
+ groups = kde-utilities-git
license = GPL
license = LGPL
license = FDL
- makedepends = extra-cmake-modules
- makedepends = kdoctools
makedepends = git
- makedepends = python
- depends = kio
+ makedepends = extra-cmake-modules-git
+ makedepends = kdoctools-git
+ depends = kio-git
depends = hicolor-icon-theme
provides = ktimer
- conflicts = kdeutils-ktimer
conflicts = ktimer
- source = git://anongit.kde.org/ktimer.git
- sha1sums = SKIP
+ source = git+https://github.com/KDE/ktimer.git
+ sha256sums = SKIP
pkgname = ktimer-git
-
diff --git a/PKGBUILD b/PKGBUILD
index 5898eeec6250..ab4d188ddc15 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,41 +1,36 @@
-# Maintainer: Gustavo Alvarez <sl1pkn07@gmail.com>
+# Merged with official ABS ktimer PKGBUILD by João, 2021/08/25 (all respective contributors apply herein)
+# Maintainer: João Figueiredo & chaotic-aur <islandc0der@chaotic.cx>
+# Contributor: Gustavo Alvarez <sl1pkn07@gmail.com>
pkgname=ktimer-git
-pkgver=0.10.r264.a3d42f7
+pkgver=21.11.70_r468.g08ad6e6
pkgrel=1
-pkgdesc="A little tool to execute programs after some time. (GIT version)"
-url='https://www.kde.org/applications/utilities/ktimer'
-arch=('x86_64')
-license=('GPL' 'LGPL' 'FDL')
-depends=('kio' 'hicolor-icon-theme')
-makedepends=('extra-cmake-modules' 'kdoctools' 'git' 'python')
-conflicts=('kdeutils-ktimer' 'ktimer')
-provides=('ktimer')
-source=('git://anongit.kde.org/ktimer.git')
-sha1sums=('SKIP')
-install=ktimer-git.install
+pkgdesc='Countdown Launcher'
+url='https://apps.kde.org/ktimer/'
+arch=($CARCH)
+license=(GPL LGPL FDL)
+depends=(kio-git hicolor-icon-theme)
+makedepends=(git extra-cmake-modules-git kdoctools-git)
+conflicts=(${pkgname%-git})
+provides=(${pkgname%-git})
+groups=(kde-applications-git kde-utilities-git)
+source=("git+https://github.com/KDE/${pkgname%-git}.git")
+sha256sums=('SKIP')
pkgver() {
- cd ktimer
- _ver="$(cat main.cpp | grep -m1 'version\[\]' | grep -o "[[:digit:]]*" | paste -sd'.')"
- echo "${_ver}.r$(git rev-list --count HEAD).$(git rev-parse --short HEAD)"
-}
-
-prepare() {
- mkdir -p build
+ cd ${pkgname%-git}
+ _major_ver="$(grep -m1 'set *(RELEASE_SERVICE_VERSION_MAJOR' CMakeLists.txt | cut -d '"' -f2)"
+ _minor_ver="$(grep -m1 'set *(RELEASE_SERVICE_VERSION_MINOR' CMakeLists.txt | cut -d '"' -f2)"
+ _micro_ver="$(grep -m1 'set *(RELEASE_SERVICE_VERSION_MICRO' CMakeLists.txt | cut -d '"' -f2)"
+ echo "${_major_ver}.${_minor_ver}.${_micro_ver}_r$(git rev-list --count HEAD).g$(git rev-parse --short HEAD)"
}
build() {
- cd build
- cmake ../ktimer \
- -DCMAKE_BUILD_TYPE=Release \
- -DCMAKE_INSTALL_PREFIX=/usr \
- -DLIB_INSTALL_DIR=lib \
- -DKDE_INSTALL_USE_QT_SYS_PATHS=ON \
+ cmake -B build -S ${pkgname%-git} \
-DBUILD_TESTING=OFF
- make
+ cmake --build build
}
package() {
- make -C build DESTDIR="${pkgdir}" install
+ DESTDIR="$pkgdir" cmake --install build
}