summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsl1pkn072015-06-14 15:58:20 +0200
committersl1pkn072015-06-14 15:58:20 +0200
commitbbd2c6523d89d553e3500a344883e1a65e239e12 (patch)
tree59f0f2ce33e4d443aa8d5c494a5589123274a000
downloadaur-bbd2c6523d89d553e3500a344883e1a65e239e12.tar.gz
Initial commit
-rw-r--r--.SRCINFO24
-rw-r--r--.gitignore5
-rw-r--r--PKGBUILD40
-rw-r--r--ktimer-git.install12
4 files changed, 81 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e259ad226653
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,24 @@
+pkgbase = ktimer-git
+ pkgdesc = A little tool to execute programs after some time. (GIT version)
+ pkgver = r264.a3d42f7
+ pkgrel = 1
+ url = https://www.kde.org/applications/utilities/ktimer
+ install = ktimer-git.install
+ arch = x86_64
+ license = GPL
+ license = LGPL
+ license = FDL
+ makedepends = extra-cmake-modules
+ makedepends = kdoctools
+ makedepends = git
+ makedepends = python
+ depends = kio
+ depends = hicolor-icon-theme
+ provides = ktimer
+ conflicts = kdeutils-ktimer
+ conflicts = ktimer
+ source = git://anongit.kde.org/ktimer.git
+ sha1sums = SKIP
+
+pkgname = ktimer-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..bc5431abd279
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+*
+!.gitignore
+!.SRCINFO
+!PKGBUILD
+!ktimer-git.install
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8dbcc9788c6f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,40 @@
+# Maintainer: Gustavo Alvarez <sl1pkn07@gmail.com>
+
+pkgname=ktimer-git
+pkgver=r264.a3d42f7
+pkgrel=1
+pkgdesc="A little tool to execute programs after some time. (GIT version)"
+url='https://www.kde.org/applications/utilities/ktimer'
+arch=('x86_64')
+license=('GPL' 'LGPL' 'FDL')
+depends=('kio' 'hicolor-icon-theme')
+makedepends=('extra-cmake-modules' 'kdoctools' 'git' 'python')
+conflicts=('kdeutils-ktimer' 'ktimer')
+provides=('ktimer')
+source=("git://anongit.kde.org/ktimer.git")
+sha1sums=('SKIP')
+install=ktimer-git.install
+
+pkgver() {
+ cd ktimer
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+prepare() {
+ mkdir -p build
+}
+
+build() {
+ cd build
+ cmake ../ktimer \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DLIB_INSTALL_DIR=lib \
+ -DKDE_INSTALL_USE_QT_SYS_PATHS=ON \
+ -DBUILD_TESTING=OFF
+ make
+}
+
+package() {
+ make -C build DESTDIR="${pkgdir}" install
+}
diff --git a/ktimer-git.install b/ktimer-git.install
new file mode 100644
index 000000000000..ba9440318d98
--- /dev/null
+++ b/ktimer-git.install
@@ -0,0 +1,12 @@
+post_install() {
+ xdg-icon-resource forceupdate --theme hicolor &> /dev/null
+ update-desktop-database -q
+}
+
+post_upgrade() {
+ post_install
+}
+
+post_remove() {
+ post_install
+} \ No newline at end of file