summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJesse Jaara2018-07-12 10:43:50 +0300
committerJesse Jaara2018-07-12 10:49:28 +0300
commitb4480c08f09d079d66e785dfa35a91935306b89c (patch)
tree5cc127df2142f178c753084a67129b5184574b19
downloadaur-b4480c08f09d079d66e785dfa35a91935306b89c.tar.gz
Add ktlint package.
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD26
2 files changed, 44 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..cf73da092b70
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = ktlint
+ pkgdesc = An anti-bikeshedding Kotlin linter with built-in formatter
+ pkgver = 0.24.0
+ pkgrel = 1
+ url = https://ktlint.github.io/
+ arch = any
+ license = CUSTOM: MIT
+ depends = java-runtime
+ source = https://github.com/shyiko/ktlint/releases/download/0.24.0/ktlint
+ source = https://raw.githubusercontent.com/shyiko/ktlint/0.24.0/LICENSE
+ source = https://github.com/shyiko/ktlint/releases/download/0.24.0/ktlint.asc
+ validpgpkeys = 160A7A9CF46221A56B06AD64461A804F2609FD89
+ sha256sums = 701ed9478a9d217f3b82efda0fa9db3e4028b3951066b6ad99e0db6c6d7c9370
+ sha256sums = 94fcaa8988fceec75f68ae8b31bb51676e4afc2534072b6e634a986700804f94
+ sha256sums = SKIP
+
+pkgname = ktlint
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e0b876a955d4
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Jesse Jaara <gmail.com: jesse.jaara>
+# Contributor: p2k <uni-ulm.de: Patrick.Schneider>
+
+pkgname=ktlint
+pkgver=0.24.0
+pkgrel=1
+pkgdesc="An anti-bikeshedding Kotlin linter with built-in formatter"
+arch=('any')
+url="https://ktlint.github.io/"
+license=('CUSTOM: MIT')
+depends=('java-runtime')
+validpgpkeys=(160A7A9CF46221A56B06AD64461A804F2609FD89)
+source=(https://github.com/shyiko/ktlint/releases/download/${pkgver}/ktlint
+ https://raw.githubusercontent.com/shyiko/ktlint/${pkgver}/LICENSE
+ https://github.com/shyiko/ktlint/releases/download/${pkgver}/ktlint.asc)
+sha256sums=('701ed9478a9d217f3b82efda0fa9db3e4028b3951066b6ad99e0db6c6d7c9370'
+ '94fcaa8988fceec75f68ae8b31bb51676e4afc2534072b6e634a986700804f94'
+ 'SKIP')
+
+package() {
+ cd "${srcdir}"
+
+ install -D -m755 ktlint "${pkgdir}/usr/bin/ktlint"
+ install -D -m644 LICENSE "${pkgdir}/usr/share/license/ktlint/LICENSE"
+}
+