summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Kirchner2017-02-25 12:31:14 +0100
committerDaniel Kirchner2017-02-25 12:31:14 +0100
commit10d4bc3517c4b5d72631866e56e6b573a5b5755b (patch)
tree6eb53125a396519004f478b80a829579369c16e7
parent549cadd2f60a376182dff47066ff20c4f21fd491 (diff)
downloadaur-10d4bc3517c4b5d72631866e56e6b573a5b5755b.tar.gz
workaround glfw3 cmake build issue
Thanks to Lubosz Sarnecki.
-rw-r--r--.SRCINFO6
-rw-r--r--0001-hack-to-fix-build-on-Arch.patch23
-rw-r--r--PKGBUILD11
3 files changed, 36 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 47af6e6b4a81..446466c033fc 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,8 @@
+# Generated by mksrcinfo v8
+# Sat Feb 25 11:30:45 UTC 2017
pkgbase = ktxutils-git
pkgdesc = Utilities for the KTX texture format
- pkgver = r14.78391f6
+ pkgver = r18.cb431ba
pkgrel = 1
url = http://github.com/ekpyron/ktxutils/
arch = any
@@ -10,7 +12,9 @@ pkgbase = ktxutils-git
depends = imagemagick
depends = glew
source = git+git://github.com/ekpyron/ktxutils
+ source = 0001-hack-to-fix-build-on-Arch.patch
md5sums = SKIP
+ md5sums = 7d4d3bd2bdf79b2ac99d3306f54539b7
pkgname = ktxutils-git
diff --git a/0001-hack-to-fix-build-on-Arch.patch b/0001-hack-to-fix-build-on-Arch.patch
new file mode 100644
index 000000000000..44c6ad34c0fe
--- /dev/null
+++ b/0001-hack-to-fix-build-on-Arch.patch
@@ -0,0 +1,23 @@
+From 9a601bb958bf5c5a810bede9fdcf6aa1436a35b0 Mon Sep 17 00:00:00 2001
+From: Lubosz Sarnecki <lubosz.sarnecki@collabora.co.uk>
+Date: Thu, 16 Feb 2017 21:54:57 +0100
+Subject: [PATCH] hack to fix build on Arch.
+
+---
+ CMakeLists.txt | 2 ++
+ 1 file changed, 2 insertions(+)
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 7030dd5..4a1154d 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -2,4 +2,6 @@ cmake_minimum_required (VERSION 2.8.11)
+
+ project (ktxutils)
+
++set(GLFW3_LIBRARY glfw)
++
+ add_subdirectory (src)
+--
+2.11.1
+
diff --git a/PKGBUILD b/PKGBUILD
index c88528da36cd..43aa905ad000 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Daniel Kirchner <daniel at ekpyron dot org>
pkgname=ktxutils-git
_pkgbase=ktxutils
-pkgver=r14.78391f6
+pkgver=r18.e55bfcb
pkgrel=1
pkgdesc="Utilities for the KTX texture format"
license=('MIT')
@@ -9,8 +9,13 @@ arch=('any')
url="http://github.com/ekpyron/${_pkgbase}/"
depends=('glfw' 'imagemagick' 'glew')
makedepends=('cmake')
-source=("git+git://github.com/ekpyron/${_pkgbase}")
-md5sums=('SKIP')
+source=("git+git://github.com/ekpyron/${_pkgbase}" 0001-hack-to-fix-build-on-Arch.patch)
+md5sums=('SKIP' '7d4d3bd2bdf79b2ac99d3306f54539b7')
+
+prepare() {
+ cd "$srcdir"/${_pkgbase}
+ git am ../0001-hack-to-fix-build-on-Arch.patch
+}
pkgver() {
cd "$srcdir"/${_pkgbase}