summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorZachary Elliott2016-08-23 22:18:58 -0400
committerZachary Elliott2016-08-23 22:18:58 -0400
commit01ca8b1b1441a5317f548ee90ec98317c9bbbec6 (patch)
tree9922db14451322de4c8f6f018bc1554bbdf5f5ca
downloadaur-01ca8b1b1441a5317f548ee90ec98317c9bbbec6.tar.gz
Create kube-aws package
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD18
2 files changed, 30 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..cc4ca3f3ad9a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,12 @@
+pkgbase = kube-aws
+ pkgdesc = CLI tool to automate Kubernetes cluster deployment to AWS
+ pkgver = v0.8.1
+ pkgrel = 1
+ url = https://github.com/coreos/coreos-kubernetes
+ arch = x86_64
+ license = Apache
+ source = https://github.com/coreos/coreos-kubernetes/releases/download/v0.8.1/kube-aws-linux-amd64.tar.gz
+ sha512sums = d64d21b93e9ed38af9dc0b6141631087921292e947231c651f359a37c0c9ead609dfa44a299b6269c5a9c7b468c1d9593fe19a05527851f0da64c98235f2219f
+
+pkgname = kube-aws
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..eeb1d7f9b99e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,18 @@
+# Maintainer: Zachary Elliott <contact@zell.io>
+# https://github.com/zellio/pkgbuild
+
+pkgname=kube-aws
+pkgver=v0.8.1
+pkgrel=1
+pkgdesc="CLI tool to automate Kubernetes cluster deployment to AWS"
+arch=('x86_64')
+url="https://github.com/coreos/coreos-kubernetes"
+license=('Apache')
+makedepends=()
+
+source=("https://github.com/coreos/coreos-kubernetes/releases/download/${pkgver}/kube-aws-linux-amd64.tar.gz")
+sha512sums=('d64d21b93e9ed38af9dc0b6141631087921292e947231c651f359a37c0c9ead609dfa44a299b6269c5a9c7b468c1d9593fe19a05527851f0da64c98235f2219f')
+
+package() {
+ install -D -g root -m 0755 -o root "$srcdir/linux-amd64/kube-aws" "$pkgdir/usr/bin/kube-aws"
+}