aboutsummarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMike Williamson2018-10-23 22:31:58 -0400
committerMike Williamson2018-10-23 22:31:58 -0400
commit00e9881c5a31ffdc6203a9944e23ffb69c526445 (patch)
treeaafa8c1df92ba86f03adab2aa4b3adc8ccbe760d
downloadaur-00e9881c5a31ffdc6203a9944e23ffb69c526445.tar.gz
Initial commit of version 0.0.22
-rw-r--r--.SRCINFO17
-rw-r--r--.gitignore5
-rw-r--r--PKGBUILD29
-rw-r--r--README.md3
4 files changed, 54 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c5bb8def8412
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = kube-bench
+ pkgdesc = Checks whether Kubernetes is deployed according to security best practices
+ pkgver = 0.0.22
+ pkgrel = 1
+ url = https://github.com/aquasecurity/kube-bench
+ arch = x86_64
+ arch = i686
+ license = APACHE
+ makedepends = go
+ makedepends = dep
+ options = !strip
+ options = !emptydirs
+ source = https://github.com/aquasecurity/kube-bench/archive/v0.0.22.tar.gz
+ md5sums = ca99b47218a4d431aeeceeb22fc4ae2f
+
+pkgname = kube-bench
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..783c30fd45da
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+*.tar.gz
+pkg
+src
+*.tar.xz
+*.swp
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..09a6e0a11a3f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Mike Williamson <mike at korora dot ca>
+
+pkgname=kube-bench
+pkgver=0.0.22
+pkgrel=1
+pkgdesc="Checks whether Kubernetes is deployed according to security best practices"
+arch=('x86_64' 'i686')
+url="https://github.com/aquasecurity/kube-bench"
+license=('APACHE')
+makedepends=('go' 'dep')
+options=('!strip' '!emptydirs')
+source=("https://github.com/aquasecurity/kube-bench/archive/v$pkgver.tar.gz")
+md5sums=('ca99b47218a4d431aeeceeb22fc4ae2f')
+
+build() {
+ mkdir "$srcdir/src"
+ mv "$srcdir/kube-bench-$pkgver" "$srcdir/src"
+ cd "$srcdir/src/kube-bench-$pkgver"
+ GOPATH="$srcdir" dep ensure
+ GOPATH="$srcdir" make
+}
+
+package() {
+ mkdir -p "$pkgdir/usr/bin"
+ install -p -m 755 "$srcdir/src/kube-bench-$pkgver/kube-bench" "$pkgdir/usr/bin"
+ install -Dm644 "$srcdir/src/kube-bench-$pkgver/LICENSE" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}
+
+# vim:set ts=2 sw=2 et:
diff --git a/README.md b/README.md
new file mode 100644
index 000000000000..c1fe9b833837
--- /dev/null
+++ b/README.md
@@ -0,0 +1,3 @@
+# Kube-bench for ArchLinux
+
+This is an Archlinux package for [Aqua Security's](https://www.aquasec.com/) [Kube-bench](https://github.com/aquasecurity/kube-bench) tool