summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDominic Brekau2022-01-20 19:03:34 +0100
committerDominic Brekau2022-01-20 19:03:34 +0100
commit66843462b585be60fc4ef66fda907336c2c9dd3f (patch)
tree023022f9279a6e6db48a08f2effa399fea58b029
parent7c69d0d8cd811902f3a78e800def10e0877fdd9c (diff)
downloadaur-66843462b585be60fc4ef66fda907336c2c9dd3f.tar.gz
Change to go-yp (before yp2-bin from AUR)
Update 1.0.6 -> 1.0.7
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD12
2 files changed, 11 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f259184bae6d..5ca8945dc5d0 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,14 @@
pkgbase = kube-dump
pkgdesc = Backup a Kubernetes cluster as a yaml manifest
- pkgver = 1.0.6
- pkgrel = 2
+ pkgver = 1.0.7
+ pkgrel = 1
url = https://github.com/WoozyMasta/kube-dump
arch = x86_64
license = GPL3
depends = kubectl
depends = jq
- depends = yq2-bin
- source = https://github.com/WoozyMasta/kube-dump/releases/download/v1.0.6/kube-dump
- sha256sums = 6e239d3cb80de09f56d6408683e7d3a5cc1e8692e25df54998021e533a5040b2
+ depends = go-yq
+ source = https://github.com/WoozyMasta/kube-dump/archive/refs/tags/1.0.7.tar.gz
+ sha256sums = d120849899ee9154a4c7de1fe20568563ec2712797f29d538192b122a040e46f
pkgname = kube-dump
diff --git a/PKGBUILD b/PKGBUILD
index b75388e36caf..f8e5845f5b0f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,17 +1,17 @@
# Maintainer: Dominic Brekau <aur@dominic.brekau.de>
pkgname=kube-dump
-pkgver=1.0.6
-pkgrel=2
+pkgver=1.0.7
+pkgrel=1
pkgdesc='Backup a Kubernetes cluster as a yaml manifest'
arch=('x86_64')
url='https://github.com/WoozyMasta/kube-dump'
-depends=('kubectl' 'jq' 'yq2-bin')
+depends=('kubectl' 'jq' 'go-yq')
license=('GPL3')
-source=("https://github.com/WoozyMasta/kube-dump/releases/download/v${pkgver}/kube-dump")
-sha256sums=('6e239d3cb80de09f56d6408683e7d3a5cc1e8692e25df54998021e533a5040b2')
+source=("https://github.com/WoozyMasta/${pkgname}/archive/refs/tags/${pkgver}.tar.gz")
+sha256sums=('d120849899ee9154a4c7de1fe20568563ec2712797f29d538192b122a040e46f')
package() {
- install -Dm 755 "$srcdir/kube-dump" -t "$pkgdir/usr/bin"
+ install -Dm 755 "$srcdir/${pkgname}-${pkgver}/kube-dump" -t "$pkgdir/usr/bin"
}