summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMatthias Lisin2019-09-18 21:38:41 +0200
committerMatthias Lisin2019-09-18 21:38:41 +0200
commit1867a12d9a1868fdaca95e5a432a46e489cab90b (patch)
tree22740e34f734ea7eb29308a29efe9e7b69d9bb09
parentf508899ba32b23bd32a389c6b4f63884b569f0f1 (diff)
downloadaur-1867a12d9a1868fdaca95e5a432a46e489cab90b.tar.gz
upgpkg: kube-prompt-git
- Replace `any` with `x86_64`, `i686` and `aarch64` - Use `-trimpath`
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD7
2 files changed, 7 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2897de77bd29..eb3ff4c5266a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,11 @@
pkgbase = kube-prompt-git
pkgdesc = An interactive kubernetes client featuring auto-complete using go-prompt.
- pkgver = 1.0.6.r3.gb3d8014
+ pkgver = 1.0.8.r0.geed9b10
pkgrel = 1
url = https://github.com/c-bata/kube-prompt
- arch = any
+ arch = x86_64
+ arch = i686
+ arch = aarch64
license = MIT
makedepends = git
makedepends = go
diff --git a/PKGBUILD b/PKGBUILD
index 9cd56db940d6..59d4c536c1ed 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,9 +1,9 @@
# Maintainer: Matthias Lisin <ml@visu.li>
pkgname=kube-prompt-git
pkgrel=1
-pkgver=1.0.6.r3.gb3d8014
+pkgver=1.0.8.r0.geed9b10
pkgdesc='An interactive kubernetes client featuring auto-complete using go-prompt.'
-arch=(any)
+arch=('x86_64' 'i686' 'aarch64')
url='https://github.com/c-bata/kube-prompt'
license=('MIT')
depends=('kubectl')
@@ -25,8 +25,7 @@ build() {
LDFLAGS+=" -X 'main.revision=$(git rev-parse --short HEAD)'"
go build \
-o kube-prompt \
- -gcflags "all=-trimpath=${PWD}" \
- -asmflags "all=-trimpath=${PWD}" \
+ -trimpath \
-ldflags "-extldflags ${LDFLAGS}"
}