summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMax Zhao2018-05-15 23:04:04 +0200
committerMax Zhao2018-05-15 23:04:04 +0200
commit841be08d59f5475e217a277bc61f4e457e025277 (patch)
treecc891e7e550ddeaa85d5d220014a3544d0e1960b
downloadaur-841be08d59f5475e217a277bc61f4e457e025277.tar.gz
Initial commit
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD25
2 files changed, 39 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b476401a7461
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = kube-spawn
+ pkgdesc = A tool for creating multi-node Kubernetes clusters on a Linux machine using kubeadm & systemd-nspawn. Brought to you by the Kinvolk team. https://kinvolk.io
+ pkgver = 0.2.1
+ pkgrel = 1
+ url = https://github.com/kinvolk/kube-spawn
+ arch = any
+ license = Apache
+ makedepends = docker
+ depends = cni-plugins
+ source = https://github.com/kinvolk/kube-spawn/archive/v0.2.1.tar.gz
+ md5sums = 7c42f8c0ae240efabaf5f6ecf95721e1
+
+pkgname = kube-spawn
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..297ce59497c3
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Max Zhao <alcasa.mz@gmail.com>
+pkgname=kube-spawn
+pkgver=0.2.1
+pkgrel=1
+pkgdesc="A tool for creating multi-node Kubernetes clusters on a Linux machine using kubeadm & systemd-nspawn. Brought to you by the Kinvolk team. https://kinvolk.io"
+arch=("any")
+url="https://github.com/kinvolk/kube-spawn"
+license=('Apache')
+depends=("cni-plugins")
+makedepends=("docker")
+source=(
+"https://github.com/kinvolk/$pkgname/archive/v$pkgver.tar.gz"
+)
+md5sums=('7c42f8c0ae240efabaf5f6ecf95721e1')
+
+build() {
+ cd "$pkgname-$pkgver"
+ make DOCKERIZED=y
+}
+
+package() {
+ cd "$pkgname-$pkgver"
+ mkdir -p $pkgdir/usr/bin
+ make PREFIX=$pkgdir/usr install
+}