summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorOlivier Le Moal2020-08-11 12:24:12 +0200
committerOlivier Le Moal2020-08-11 12:24:12 +0200
commita2a1c1ccf883a12f1ff40f2308670c2fa71a1f4f (patch)
tree2e01c88c8ccfa888034c19925b36978466b6b5e2
downloadaur-a2a1c1ccf883a12f1ff40f2308670c2fa71a1f4f.tar.gz
first commit
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD16
2 files changed, 28 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..2b01c12b46fb
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,12 @@
+pkgbase = kubeaudit-bin
+ pkgdesc = kubeaudit is a command line tool and a Go package to audit Kubernetes clusters for various different security concerns.
+ pkgver = 0.9.0
+ pkgrel = 1
+ url = https://github.com/Shopify/kubeaudit
+ arch = x86_64
+ license = MIT
+ source = https://github.com/Shopify/kubeaudit/releases/download/v0.9.0/kubeaudit_0.9.0_linux_amd64.tar.gz
+ sha256sums = 08ef3f6797b26be9a7c2f572aa6b0ab771f2ce60dc4c68dfcf1bf6109871c05d
+
+pkgname = kubeaudit-bin
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..45b9f2a994ef
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,16 @@
+# Maintainer: Olivier Le Moal <mail at olivierlemoal dot fr>
+
+pkgname=kubeaudit-bin
+pkgver=0.9.0
+pkgrel=1
+pkgdesc="kubeaudit is a command line tool and a Go package to audit Kubernetes clusters for various different security concerns."
+arch=('x86_64')
+url="https://github.com/Shopify/kubeaudit"
+license=('MIT')
+source=("https://github.com/Shopify/kubeaudit/releases/download/v${pkgver}/kubeaudit_${pkgver}_linux_amd64.tar.gz")
+sha256sums=('08ef3f6797b26be9a7c2f572aa6b0ab771f2ce60dc4c68dfcf1bf6109871c05d')
+
+package() {
+ install -d "${pkgdir}/usr/bin"
+ install -D -m755 kubeaudit -t "${pkgdir}/usr/bin"
+}