summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBrad Erhart2021-02-19 18:07:00 -0800
committerBrad Erhart2021-02-19 18:07:00 -0800
commitdbd230d4f39ef9b291f7fa281f6efa67b59b302e (patch)
tree721def4e0dff66c59121ca03d2525b3c5dd086af
downloadaur-dbd230d4f39ef9b291f7fa281f6efa67b59b302e.tar.gz
Creating initial package for preflight kubectl plugin v0.10.5
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD22
2 files changed, 37 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..2cd5632f63ab
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = kubectl-preflight-bin
+ pkgdesc = Kubectl plugin for pre-installation cluster conformance testing and validation (preflight checks)
+ pkgver = 0.10.5
+ pkgrel = 1
+ url = https://troubleshoot.sh
+ arch = x86_64
+ license = Apache
+ depends = kubectl
+ provides = kubectl-preflight
+ conflicts = kubectl-preflight
+ source = preflight_0.10.5_linux_amd64.tar.gz::https://github.com/replicatedhq/troubleshoot/releases/download/v0.10.5/preflight_linux_amd64.tar.gz
+ sha256sums = 9b11f6ee5536a9c6928e88b73a7884268d56c06459e768610e7d2be5cad58948
+
+pkgname = kubectl-preflight-bin
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..497e3cf2f740
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+# Maintainer: Brad Erhart <brae dot 04 plus aur at gmail dot com>
+
+pkgname=kubectl-preflight-bin
+_pkgname="${pkgname%-bin}"
+_pkgname2="${_pkgname#kubectl-}"
+pkgver=0.10.5
+pkgrel=1
+pkgdesc='Kubectl plugin for pre-installation cluster conformance testing and validation (preflight checks)'
+arch=('x86_64')
+_goos='linux'
+_goarch='amd64'
+url="https://troubleshoot.sh"
+license=('Apache')
+depends=('kubectl')
+provides=("$_pkgname")
+conflicts=("$_pkgname")
+source=("${_pkgname2}_${pkgver}_${_goos}_${_goarch}.tar.gz::https://github.com/replicatedhq/troubleshoot/releases/download/v$pkgver/${_pkgname2}_${_goos}_${_goarch}.tar.gz")
+sha256sums=(9b11f6ee5536a9c6928e88b73a7884268d56c06459e768610e7d2be5cad58948)
+
+package() {
+ install -Dm 755 "${_pkgname2}" "$pkgdir/usr/bin/${_pkgname}"
+}