summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBrad Erhart2021-06-29 21:14:19 -0700
committerBrad Erhart2021-06-29 21:14:19 -0700
commite100a312a6fa59e0ea087aa4e6cd3a0de4176f50 (patch)
treeee0d37aaf058f53c604d67eae803b7d3b99fa423
parent1bef7adaae149d5117904c7eded47a27ed5e2e99 (diff)
downloadaur-e100a312a6fa59e0ea087aa4e6cd3a0de4176f50.tar.gz
Updating support-bundle kubectl plugin to v0.11.0
-rw-r--r--.SRCINFO7
-rw-r--r--.gitignore3
-rw-r--r--PKGBUILD4
3 files changed, 8 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 530f7afc07d1..0408989457c5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = kubectl-support-bundle-bin
pkgdesc = Kubectl plugin for post-installation troubleshooting and diagnostics (support bundles)
- pkgver = 0.10.24
+ pkgver = 0.11.0
pkgrel = 1
url = https://troubleshoot.sh
arch = x86_64
@@ -8,8 +8,7 @@ pkgbase = kubectl-support-bundle-bin
depends = kubectl
provides = kubectl-support-bundle
conflicts = kubectl-support-bundle
- source = support-bundle_0.10.24_linux_amd64.tar.gz::https://github.com/replicatedhq/troubleshoot/releases/download/v0.10.24/support-bundle_linux_amd64.tar.gz
- sha256sums = 3934f9ea4820366e873ab2b3f90edf9d8fcb090489378e0c928510910e7e7d6f
+ source = support-bundle_0.11.0_linux_amd64.tar.gz::https://github.com/replicatedhq/troubleshoot/releases/download/v0.11.0/support-bundle_linux_amd64.tar.gz
+ b2sums = 47825fb3005cefe9362442943eb5de457f0b0fa1264f62d9a173f86e51a80690270a6992ca08bd0196c2a3a9527c76df725de9175ffc488d39ab3e4708c1447b
pkgname = kubectl-support-bundle-bin
-
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..8538eeef183b
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,3 @@
+*support-bundle*
+pkg
+src
diff --git a/PKGBUILD b/PKGBUILD
index 6c0d0c4aef59..aa983d9356a9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgname=kubectl-support-bundle-bin
_pkgname="${pkgname%-bin}"
_pkgname2="${_pkgname#kubectl-}"
-pkgver=0.10.24
+pkgver=0.11.0
pkgrel=1
pkgdesc='Kubectl plugin for post-installation troubleshooting and diagnostics (support bundles)'
arch=('x86_64')
@@ -15,7 +15,7 @@ depends=('kubectl')
provides=("$_pkgname")
conflicts=("$_pkgname")
source=("${_pkgname2}_${pkgver}_${_goos}_${_goarch}.tar.gz::https://github.com/replicatedhq/troubleshoot/releases/download/v$pkgver/${_pkgname2}_${_goos}_${_goarch}.tar.gz")
-sha256sums=(3934f9ea4820366e873ab2b3f90edf9d8fcb090489378e0c928510910e7e7d6f)
+b2sums=(47825fb3005cefe9362442943eb5de457f0b0fa1264f62d9a173f86e51a80690270a6992ca08bd0196c2a3a9527c76df725de9175ffc488d39ab3e4708c1447b)
package() {
install -Dm 755 "${_pkgname2}" "$pkgdir/usr/bin/kubectl-${_pkgname2/-/_}"