summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBrad Erhart2021-02-19 18:09:02 -0800
committerBrad Erhart2021-02-19 18:09:02 -0800
commitea06849569335f94becf67d21618b3db23faa91f (patch)
treed9d10b69ab672e7a37d2ea2d4d020e3dce3ec6ad
downloadaur-ea06849569335f94becf67d21618b3db23faa91f.tar.gz
Creating initial package for support-bundle kubectl plugin v0.10.5
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD22
2 files changed, 37 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..cb84ab71bbf6
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = kubectl-support-bundle-bin
+ pkgdesc = Kubectl plugin for post-installation troubleshooting and diagnostics (support bundles)
+ pkgver = 0.10.5
+ pkgrel = 1
+ url = https://troubleshoot.sh
+ arch = x86_64
+ license = Apache
+ depends = kubectl
+ provides = kubectl-support-bundle
+ conflicts = kubectl-support-bundle
+ source = support-bundle_0.10.5_linux_amd64.tar.gz::https://github.com/replicatedhq/troubleshoot/releases/download/v0.10.5/support-bundle_linux_amd64.tar.gz
+ sha256sums = 81b6768ade52a8021327781fa906e26d6279242ecd84f899f9fa7d7f132f585e
+
+pkgname = kubectl-support-bundle-bin
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ca918d675ea3
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+# Maintainer: Brad Erhart <brae dot 04 plus aur at gmail dot com>
+
+pkgname=kubectl-support-bundle-bin
+_pkgname="${pkgname%-bin}"
+_pkgname2="${_pkgname#kubectl-}"
+pkgver=0.10.5
+pkgrel=1
+pkgdesc='Kubectl plugin for post-installation troubleshooting and diagnostics (support bundles)'
+arch=('x86_64')
+_goos='linux'
+_goarch='amd64'
+url="https://troubleshoot.sh"
+license=('Apache')
+depends=('kubectl')
+provides=("$_pkgname")
+conflicts=("$_pkgname")
+source=("${_pkgname2}_${pkgver}_${_goos}_${_goarch}.tar.gz::https://github.com/replicatedhq/troubleshoot/releases/download/v$pkgver/${_pkgname2}_${_goos}_${_goarch}.tar.gz")
+sha256sums=(81b6768ade52a8021327781fa906e26d6279242ecd84f899f9fa7d7f132f585e)
+
+package() {
+ install -Dm 755 "${_pkgname2}" "$pkgdir/usr/bin/${_pkgname}"
+}