summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJohn Lane2020-02-21 15:03:54 +0000
committerJohn Lane2020-02-21 15:03:54 +0000
commit744e4311937eb9f20a7ef5e58c3a94208e358d3b (patch)
treea1b7a0f838a7198a331c29f741427f3570185a09
downloadaur-744e4311937eb9f20a7ef5e58c3a94208e358d3b.tar.gz
Initial Commit
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD24
2 files changed, 40 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ef260ef45705
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = kubergrunt-bin
+ pkgdesc = A standalone go binary with a collection of commands that attempts to fill in the gaps between Terraform, Helm, and Kubectl for managing a Kubernetes Cluster.
+ pkgver = 0.5.8
+ pkgrel = 1
+ url = https://github.com/gruntwork-io/kubergrunt
+ arch = x86_64
+ license = Apache
+ provides = kubergrunt
+ conflicts = kubergrunt
+ source = https://raw.githubusercontent.com/gruntwork-io/kubergrunt/v0.5.8/LICENSE
+ source = kubergrunt_linux_amd64-0.5.8::https://github.com/gruntwork-io/kubergrunt/releases/download/v0.5.8/kubergrunt_linux_amd64
+ sha256sums = d1dc9a105a814822337e0f8eab8668e4eb05bb04b4d6b234c5e9b79b76550a91
+ sha256sums = 243befe86a0c4eabc4cac40800dadc07478e7cf4edb542f59d76e3ebe22701c4
+
+pkgname = kubergrunt-bin
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5022e571f506
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: John Lane <archlinux at jelmail.com>
+
+pkgname=kubergrunt-bin
+pkgver=0.5.8
+pkgrel=1
+pkgdesc="A standalone go binary with a collection of commands that attempts to fill in the gaps between Terraform, Helm, and Kubectl for managing a Kubernetes Cluster."
+url="https://github.com/gruntwork-io/kubergrunt"
+conflicts=('kubergrunt')
+provides=('kubergrunt')
+license=('Apache')
+arch=('x86_64')
+source=(
+ "https://raw.githubusercontent.com/gruntwork-io/kubergrunt/v${pkgver}/LICENSE"
+ "kubergrunt_linux_amd64-${pkgver}::https://github.com/gruntwork-io/kubergrunt/releases/download/v${pkgver}/kubergrunt_linux_amd64"
+)
+sha256sums=('d1dc9a105a814822337e0f8eab8668e4eb05bb04b4d6b234c5e9b79b76550a91'
+ '243befe86a0c4eabc4cac40800dadc07478e7cf4edb542f59d76e3ebe22701c4')
+
+package() {
+ install -D -m 644 "${srcdir}/LICENSE" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ install -D -m 755 "${srcdir}/${source[1]%%::*}" "${pkgdir}/usr/bin/${pkgname%-bin}"
+}
+
+# vim:set ts=2 sw=2 et: