summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLukas Grossar2020-03-24 22:12:08 +0100
committerLukas Grossar2020-03-24 22:18:40 +0100
commit2b6dcdac43f6a27c850d71e0db8c36ca3b4f7d94 (patch)
treeb923df7846a6af5f65706d3b8b1285a64bfcbea9
parente3587b6b3a26a0fc4ace78d371b85ea3635a2f3c (diff)
downloadaur-kubernetes-helm.tar.gz
Remove conflict with helm
There's no conflict anymore since helm has beeen renamed to helm-synth.
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD5
2 files changed, 3 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9993a02a5a3b..625731fbf795 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = kubernetes-helm
pkgdesc = A tool to manage Kubernetes charts
pkgver = 3.1.2
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/helm/helm
arch = i686
arch = x86_64
@@ -11,7 +11,6 @@ pkgbase = kubernetes-helm
makedepends = go
makedepends = git
depends = glibc
- conflicts = helm
source = kubernetes-helm-3.1.2.tar.gz::https://github.com/helm/helm/archive/v3.1.2.tar.gz
sha256sums = 06c7a43be1841b07c4737999d90c1d194b80b55c6d80829349121e8e95f4a1e1
diff --git a/PKGBUILD b/PKGBUILD
index 9f8891b29d77..2d8e58b88c13 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,19 +6,18 @@
pkgname=kubernetes-helm
pkgver=3.1.2
_commit=d878d4d45863e42fd5cff6743294a11d28a9abce
-pkgrel=1
+pkgrel=2
pkgdesc="A tool to manage Kubernetes charts"
arch=('i686' 'x86_64' 'arm' 'aarch64')
url="https://github.com/helm/helm"
depends=('glibc')
makedepends=('go' 'git')
-conflicts=('helm')
license=('Apache')
source=("${pkgname}-${pkgver}.tar.gz::https://github.com/helm/helm/archive/v${pkgver}.tar.gz")
sha256sums=('06c7a43be1841b07c4737999d90c1d194b80b55c6d80829349121e8e95f4a1e1')
build() {
- cd "$srcdir/helm-${pkgver}"
+ cd helm-${pkgver}
go build -o bin/helm \
-buildmode=pie \
-trimpath \