summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLukas Grossar2018-09-25 21:48:16 +0200
committerLukas Grossar2018-09-25 21:48:16 +0200
commit10ac145934041ce58bd594390d6c63d9f9330937 (patch)
tree569bd214a1ba235aeada1d0d8297223c71b0e190
parent0f20a6a796e8eacf778c30815542f281808b7568 (diff)
downloadaur-10ac145934041ce58bd594390d6c63d9f9330937.tar.gz
update to v2.11.0
Patch for zsh completion removed, the bug has been fixed upstream.
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD11
-rw-r--r--add_compdef_zsh_completion.patch7
3 files changed, 8 insertions, 24 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 85461cc0382f..4a4979cac34e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = kubernetes-helm
pkgdesc = A tool to manage Kubernetes charts
- pkgver = 2.10.0
+ pkgver = 2.11.0
pkgrel = 1
url = https://github.com/kubernetes/helm
arch = i686
@@ -8,14 +8,10 @@ pkgbase = kubernetes-helm
license = Apache
depends = socat
optdepends = kubectl-bin: Check Kubernetes status
- source_i686 = https://kubernetes-helm.storage.googleapis.com/helm-v2.10.0-linux-386.tar.gz
- source_i686 = add_compdef_zsh_completion.patch
- sha512sums_i686 = 30772e84fddfb85e1962c2a9abd6c2d9692ecc346693c8be034cdd727fc2a79cc987fe926b138133602785e8786e64b58c4c4fdb99280a41e7870edd5f7bb5fc
- sha512sums_i686 = e4a888d9e892e7a53e07159b8d6e9bfc3757b12355f7d9b2a6fc3d0890946b774a3f83d87142460440caa0d84bf1569d08a7d3a6a3b900bdb01df902367de9a3
- source_x86_64 = https://kubernetes-helm.storage.googleapis.com/helm-v2.10.0-linux-amd64.tar.gz
- source_x86_64 = add_compdef_zsh_completion.patch
- sha512sums_x86_64 = 00fd28cbfbc60796b0c232edc38655f792ccff36f3335b57ad504c90432227c88092bf8337f23ce0db83b92286fd5f133b1f7346070f17f54160dcefe470fb62
- sha512sums_x86_64 = e4a888d9e892e7a53e07159b8d6e9bfc3757b12355f7d9b2a6fc3d0890946b774a3f83d87142460440caa0d84bf1569d08a7d3a6a3b900bdb01df902367de9a3
+ source_i686 = https://kubernetes-helm.storage.googleapis.com/helm-v2.11.0-linux-386.tar.gz
+ sha512sums_i686 = d245b59c6f8c6a92894f91d01e52a2a22c77eea9ef5bc1729bcd6e34926c1a8ccf0ad2232a6a35c8d4f6f127e0ad7266f98d7d2daf8d37f38c9975f978439d7b
+ source_x86_64 = https://kubernetes-helm.storage.googleapis.com/helm-v2.11.0-linux-amd64.tar.gz
+ sha512sums_x86_64 = 0f3106d9600ffa80dede77616cf94223005ade1026abbedd9affe8544511d49a2a56385f6dfa0dfd0c020d1d682c4959ac81fd2877759f248a2fda4c48527984
pkgname = kubernetes-helm
diff --git a/PKGBUILD b/PKGBUILD
index 88276d7b1149..90192338cd22 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Lukas Grossar <lukas.grossar@gmail.com>
pkgname=kubernetes-helm
-pkgver=2.10.0
+pkgver=2.11.0
pkgrel=1
pkgdesc="A tool to manage Kubernetes charts"
arch=('i686' 'x86_64')
@@ -11,16 +11,12 @@ optdepends=('kubectl-bin: Check Kubernetes status')
license=('Apache')
source_i686=(
"https://kubernetes-helm.storage.googleapis.com/helm-v$pkgver-linux-386.tar.gz"
- "add_compdef_zsh_completion.patch"
)
source_x86_64=(
"https://kubernetes-helm.storage.googleapis.com/helm-v$pkgver-linux-amd64.tar.gz"
- "add_compdef_zsh_completion.patch"
)
-sha512sums_i686=('30772e84fddfb85e1962c2a9abd6c2d9692ecc346693c8be034cdd727fc2a79cc987fe926b138133602785e8786e64b58c4c4fdb99280a41e7870edd5f7bb5fc'
- 'e4a888d9e892e7a53e07159b8d6e9bfc3757b12355f7d9b2a6fc3d0890946b774a3f83d87142460440caa0d84bf1569d08a7d3a6a3b900bdb01df902367de9a3')
-sha512sums_x86_64=('00fd28cbfbc60796b0c232edc38655f792ccff36f3335b57ad504c90432227c88092bf8337f23ce0db83b92286fd5f133b1f7346070f17f54160dcefe470fb62'
- 'e4a888d9e892e7a53e07159b8d6e9bfc3757b12355f7d9b2a6fc3d0890946b774a3f83d87142460440caa0d84bf1569d08a7d3a6a3b900bdb01df902367de9a3')
+sha512sums_i686=('d245b59c6f8c6a92894f91d01e52a2a22c77eea9ef5bc1729bcd6e34926c1a8ccf0ad2232a6a35c8d4f6f127e0ad7266f98d7d2daf8d37f38c9975f978439d7b')
+sha512sums_x86_64=('0f3106d9600ffa80dede77616cf94223005ade1026abbedd9affe8544511d49a2a56385f6dfa0dfd0c020d1d682c4959ac81fd2877759f248a2fda4c48527984')
package() {
cd "$srcdir"
@@ -29,5 +25,4 @@ package() {
"$pkgdir/usr/bin/helm" completion bash > "$pkgdir/usr/share/bash-completion/completions/helm"
install -dm 755 "$pkgdir/usr/share/zsh/site-functions"
"$pkgdir/usr/bin/helm" completion zsh > "$pkgdir/usr/share/zsh/site-functions/_helm"
- patch "$pkgdir/usr/share/zsh/site-functions/_helm" "$srcdir/add_compdef_zsh_completion.patch"
}
diff --git a/add_compdef_zsh_completion.patch b/add_compdef_zsh_completion.patch
deleted file mode 100644
index c6d78d7bf5bd..000000000000
--- a/add_compdef_zsh_completion.patch
+++ /dev/null
@@ -1,7 +0,0 @@
---- usr/share/zsh/site-functions/_helm.orig 2018-07-18 10:24:02.775166154 +0200
-+++ usr/share/zsh/site-functions/_helm 2018-07-18 10:24:14.354810806 +0200
-@@ -1,3 +1,4 @@
-+#compdef helm
-
- __helm_bash_source() {
- alias shopt=':'