summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAnatoly Rugalev2022-04-14 00:07:38 +0200
committerAnatoly Rugalev2022-04-14 00:07:38 +0200
commit85632a1d533e500468a5ee23d4b7e5bc6fdfb209 (patch)
tree9372f0e5f6a7021869a8b5ccc54cee486ddbb198
parent971853ada61084881a3c2b92a4d2232c72b2167e (diff)
downloadaur-85632a1d533e500468a5ee23d4b7e5bc6fdfb209.tar.gz
Support aarch64, i486 and i686
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD21
-rw-r--r--PKGBUILD.tpl22
-rwxr-xr-xtest.sh5
-rwxr-xr-xupdate.sh23
5 files changed, 61 insertions, 25 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 493e1ce8b05e..8a9c24011a6b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,21 @@
pkgbase = kubernetes-helmfile-bin
pkgdesc = Deploy Kubernetes Helm Charts
pkgver = 0.144.0
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/roboll/helmfile
arch = x86_64
+ arch = aarch64
+ arch = i486
+ arch = i686
license = MIT
depends = helm
- source = helmfile_linux_amd64_0.144.0::https://github.com/roboll/helmfile/releases/download/v0.144.0/helmfile_linux_amd64
- sha256sums = dcf865a715028d3a61e2fec09f2a0beaeb7ff10cde32e096bf94aeb9a6eb4f02
+ source_x86_64 = helmfile_linux_0.144.0_x86_64::https://github.com/roboll/helmfile/releases/download/v0.144.0/helmfile_linux_amd64
+ sha256sums_x86_64 = dcf865a715028d3a61e2fec09f2a0beaeb7ff10cde32e096bf94aeb9a6eb4f02
+ source_aarch64 = helmfile_linux_0.144.0_aarch64::https://github.com/roboll/helmfile/releases/download/v0.144.0/helmfile_linux_arm64
+ sha256sums_aarch64 = 8461bbb13ba23f4333dc99d96bf7a24c283cd7683e746acf639d80bbd828926a
+ source_i486 = helmfile_linux_0.144.0_i486::https://github.com/roboll/helmfile/releases/download/v0.144.0/helmfile_linux_386
+ sha256sums_i486 = 7c75e13b062ebbe1ea09120f5ca03556895482ea92c545c13148407005eb1a66
+ source_i686 = helmfile_linux_0.144.0_i686::https://github.com/roboll/helmfile/releases/download/v0.144.0/helmfile_linux_386
+ sha256sums_i686 = 7c75e13b062ebbe1ea09120f5ca03556895482ea92c545c13148407005eb1a66
pkgname = kubernetes-helmfile-bin
diff --git a/PKGBUILD b/PKGBUILD
index 4f5d97f69932..709d51dbff74 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,18 +2,25 @@
pkgname=kubernetes-helmfile-bin
pkgver=0.144.0
-pkgrel=1
+pkgrel=2
pkgdesc="Deploy Kubernetes Helm Charts"
url="https://github.com/roboll/helmfile"
license=('MIT')
-arch=('x86_64')
+arch=('x86_64' 'aarch64' 'i486' 'i686')
depends=('helm')
-source=("helmfile_linux_amd64_$pkgver::https://github.com/roboll/helmfile/releases/download/v$pkgver/helmfile_linux_amd64")
-sha256sums=('dcf865a715028d3a61e2fec09f2a0beaeb7ff10cde32e096bf94aeb9a6eb4f02')
+source_x86_64=("helmfile_linux_${pkgver}_x86_64::https://github.com/roboll/helmfile/releases/download/v${pkgver}/helmfile_linux_amd64")
+source_i486=("helmfile_linux_${pkgver}_i486::https://github.com/roboll/helmfile/releases/download/v${pkgver}/helmfile_linux_386")
+source_i686=("helmfile_linux_${pkgver}_i686::https://github.com/roboll/helmfile/releases/download/v${pkgver}/helmfile_linux_386")
+source_aarch64=("helmfile_linux_${pkgver}_aarch64::https://github.com/roboll/helmfile/releases/download/v${pkgver}/helmfile_linux_arm64")
+
package() {
- cd "$srcdir"
- install -d "$pkgdir/usr/bin"
- install -m755 helmfile_linux_amd64_$pkgver "$pkgdir/usr/bin/helmfile"
+ cd "${srcdir}"
+ install -d "${pkgdir}/usr/bin"
+ install -m755 helmfile_linux_${pkgver}_${CARCH} "${pkgdir}/usr/bin/helmfile"
}
+sha256sums_x86_64=('dcf865a715028d3a61e2fec09f2a0beaeb7ff10cde32e096bf94aeb9a6eb4f02')
+sha256sums_aarch64=('8461bbb13ba23f4333dc99d96bf7a24c283cd7683e746acf639d80bbd828926a')
+sha256sums_i486=('7c75e13b062ebbe1ea09120f5ca03556895482ea92c545c13148407005eb1a66')
+sha256sums_i686=('7c75e13b062ebbe1ea09120f5ca03556895482ea92c545c13148407005eb1a66')
diff --git a/PKGBUILD.tpl b/PKGBUILD.tpl
new file mode 100644
index 000000000000..3046da066c83
--- /dev/null
+++ b/PKGBUILD.tpl
@@ -0,0 +1,22 @@
+# Maintainer: Anatoly Rugalev <anatoly.rugalev gmail com>
+
+pkgname=kubernetes-helmfile-bin
+pkgver=${VERSION}
+pkgrel=${PKGREL}
+pkgdesc="Deploy Kubernetes Helm Charts"
+url="https://github.com/roboll/helmfile"
+license=('MIT')
+arch=('x86_64' 'aarch64' 'i486' 'i686')
+depends=('helm')
+
+source_x86_64=("helmfile_linux_${pkgver}_x86_64::https://github.com/roboll/helmfile/releases/download/v${pkgver}/helmfile_linux_amd64")
+source_i486=("helmfile_linux_${pkgver}_i486::https://github.com/roboll/helmfile/releases/download/v${pkgver}/helmfile_linux_386")
+source_i686=("helmfile_linux_${pkgver}_i686::https://github.com/roboll/helmfile/releases/download/v${pkgver}/helmfile_linux_386")
+source_aarch64=("helmfile_linux_${pkgver}_aarch64::https://github.com/roboll/helmfile/releases/download/v${pkgver}/helmfile_linux_arm64")
+
+package() {
+ cd "${srcdir}"
+ install -d "${pkgdir}/usr/bin"
+ install -m755 helmfile_linux_${pkgver}_${CARCH} "${pkgdir}/usr/bin/helmfile"
+}
+
diff --git a/test.sh b/test.sh
new file mode 100755
index 000000000000..af080d2ac83e
--- /dev/null
+++ b/test.sh
@@ -0,0 +1,5 @@
+#!/bin/env bash
+
+set -e
+
+makepkg --install \ No newline at end of file
diff --git a/update.sh b/update.sh
index 1724a81a3b4f..f9fc719d500f 100755
--- a/update.sh
+++ b/update.sh
@@ -2,21 +2,14 @@
set -e
-VERSION=$1
+export VERSION=$1
+export PKGREL=${2:-1}
-echo $VERSION
-FILE=helmfile_linux_amd64_${VERSION}
-
-wget https://github.com/roboll/helmfile/releases/download/v${VERSION}/helmfile_linux_amd64 -O $FILE
-SUM=$(sha256sum $FILE | awk '{print $1}')
-echo $SUM
-rm $FILE
-
-sed -i /pkgver=/c\pkgver=$VERSION PKGBUILD
-sed -i /pkgrel=/c\pkgrel=1 PKGBUILD
-sed -i /sha256sums=/c\sha256sums=\(\'$SUM\'\) PKGBUILD
+envsubst '$VERSION $PKGREL' < PKGBUILD.tpl > PKGBUILD
+makepkg --geninteg >> PKGBUILD
makepkg --printsrcinfo > .SRCINFO
-git add -A
-git commit -m "Updated to v${VERSION}"
-git push
+
+#git add -A
+#git commit -m "Updated to v${VERSION}"
+#git push