summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorVianney Bouchaud2023-07-24 16:09:19 +0200
committerVianney Bouchaud2023-07-24 16:09:19 +0200
commit6ed0ce4b3e89feb8c2006aeb0f433e0e2edb64b0 (patch)
tree2b00014e578d55f81aeca5f5ff3ea36d4b434d66
downloadaur-6ed0ce4b3e89feb8c2006aeb0f433e0e2edb64b0.tar.gz
Initial upload: kubeshark-git 41.3.r12.g470ab3d7e-1
Initial upload: kubeshark 41.3-1 adding kubeshark and kubeshark-git
-rw-r--r--.SRCINFO13
-rw-r--r--.gitignore1
-rw-r--r--.norelease0
-rw-r--r--PKGBUILD49
4 files changed, 63 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e0103dab8a05
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = kubeshark
+ pkgdesc = Kubeshark is an API Traffic Analyzer for Kubernetes.
+ pkgver = 41.3
+ pkgrel = 1
+ url = https://github.com/kubeshark/kubeshark
+ arch = x86_64
+ arch = aarch64
+ license = apache
+ makedepends = go
+ source = kubeshark-41.3.tar.gz::https://github.com/kubeshark/kubeshark/archive/41.3.tar.gz
+ sha256sums = 2aa777e4f2718353937f993e47b247dc1c3c5aee215956e8cad5616baf94e3c1
+
+pkgname = kubeshark
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..8eb231c8317a
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1 @@
+kubeshark*
diff --git a/.norelease b/.norelease
new file mode 100644
index 000000000000..e69de29bb2d1
--- /dev/null
+++ b/.norelease
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..968bdf9518a9
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,49 @@
+# Maintainer: Vianney Bouchaud <aur dot vianney at bouchaud dot org>
+
+pkgname=kubeshark
+pkgdesc="Kubeshark is an API Traffic Analyzer for Kubernetes."
+pkgver=41.3
+pkgrel=1
+arch=('x86_64' 'aarch64')
+url="https://github.com/kubeshark/kubeshark"
+license=('apache')
+makedepends=(
+ 'go'
+)
+
+source=(
+ "${pkgname}-${pkgver}.tar.gz::https://github.com/kubeshark/kubeshark/archive/${pkgver}.tar.gz"
+)
+
+sha256sums=(
+ "2aa777e4f2718353937f993e47b247dc1c3c5aee215956e8cad5616baf94e3c1"
+)
+
+build() {
+ export GOPATH="$srcdir"/gopath
+ export CGO_CPPFLAGS="${CPPFLAGS}"
+ export CGO_CFLAGS="${CFLAGS}"
+ export CGO_CXXFLAGS="${CXXFLAGS}"
+ export CGO_LDFLAGS="${LDFLAGS}"
+ export CGO_ENABLED=1
+
+ cd "$srcdir/$pkgname-$pkgver"
+
+ platform=$(go version | sed -r 's/go version go.+\s(.+)/\1/' | sed -e 's/\//-/g')
+
+ go build ${GCLFAGS} \
+ -ldflags="\
+ -X 'github.com/kubeshark/kubeshark/misc.GitCommitHash=' \
+ -X 'github.com/kubeshark/kubeshark/misc.Branch=' \
+ -X 'github.com/kubeshark/kubeshark/misc.Platform=${platform}' \
+ -X 'github.com/kubeshark/kubeshark/misc.Ver=${pkgver}' \
+ -s -w" \
+ -o bin/kubeshark kubeshark.go
+}
+
+package() {
+ install -D -m0755 "${srcdir}/$pkgname-$pkgver/bin/kubeshark" "${pkgdir}/usr/bin/kubeshark"
+
+ "${pkgdir}/usr/bin/kubeshark" completion bash | install -Dm644 /dev/stdin "${pkgdir}/usr/share/bash-completion/completions/kubeshark"
+ "${pkgdir}/usr/bin/kubeshark" completion zsh | install -Dm644 /dev/stdin "${pkgdir}/usr/share/zsh/site-functions/_kubeshark"
+}