summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorOlivier Le Moal2021-10-26 23:50:33 +0200
committerOlivier Le Moal2021-10-26 23:50:33 +0200
commite312789c7abc4a61c3bb61db2c3258de51c56d18 (patch)
tree708c120c3f9d216e0799d082f891778881804e38
downloadaur-e312789c7abc4a61c3bb61db2c3258de51c56d18.tar.gz
First commit
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD15
2 files changed, 26 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..023f12327290
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,11 @@
+pkgbase = mizu-bin
+ pkgdesc = A simple-yet-powerful API traffic viewer for Kubernetes enabling you to view all API communication between microservices to help your debug and troubleshoot regressions.
+ pkgver = 0.17.2
+ pkgrel = 1
+ url = https://github.com/up9inc/mizu
+ arch = x86_64
+ license = Apache
+ source = https://github.com/up9inc/mizu/releases/download/0.17.2/mizu_linux_amd64
+ sha256sums = d9aa21a16f06487ec9c2607e1bdb26f5249e11c9c740cc0c9a43bb6f8d3abb60
+
+pkgname = mizu-bin
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8e387aabf06c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,15 @@
+# Maintainer: Olivier Le Moal <mail at olivierlemoal dot fr>
+
+pkgname=mizu-bin
+pkgver=0.17.2
+pkgrel=1
+pkgdesc="A simple-yet-powerful API traffic viewer for Kubernetes enabling you to view all API communication between microservices to help your debug and troubleshoot regressions."
+arch=('x86_64')
+url="https://github.com/up9inc/mizu"
+license=('Apache')
+source=("https://github.com/up9inc/mizu/releases/download/${pkgver}/mizu_linux_amd64")
+sha256sums=('d9aa21a16f06487ec9c2607e1bdb26f5249e11c9c740cc0c9a43bb6f8d3abb60')
+
+package() {
+ install -D -m755 mizu_linux_amd64 -t "${pkgdir}/usr/bin"
+}