summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorVianney Bouchaud2023-07-24 16:54:57 +0200
committerVianney Bouchaud2023-07-24 16:54:57 +0200
commitebbe40dcefee652f24f0ddc43e11d15f52111949 (patch)
treef198db977c11090432ea06fdab28085a8e338aeb
parentf4f783e5cee0e769b9127e3536c0c32ec7637a43 (diff)
downloadaur-ebbe40dcefee652f24f0ddc43e11d15f52111949.tar.gz
upgpkg: kubeshark-bin 41.3-2
rebasing kubeshark-bin from aur
-rw-r--r--.SRCINFO16
-rw-r--r--.gitignore1
-rw-r--r--.norelease0
-rw-r--r--PKGBUILD33
4 files changed, 36 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 38ac7b8ed085..fd1f3dd06e6d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,16 @@
pkgbase = kubeshark-bin
- pkgdesc = A simple-yet-powerful API traffic viewer for Kubernetes enabling you to view all API communication between microservices to help your debug and troubleshoot regressions.
+ pkgdesc = Kubeshark is an API Traffic Analyzer for Kubernetes.
pkgver = 41.3
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/kubeshark/kubeshark
arch = x86_64
- license = Apache
- conflicts = mizu-bin
- source = https://github.com/kubeshark/kubeshark/releases/download/41.3/kubeshark_linux_amd64
- sha256sums = 9f93bdd3779c8c809e5614f859c3f7e3c122101322f503b45551762905796526
+ arch = aarch64
+ license = apache
+ provides = kubeshark
+ conflicts = kubeshark
+ source_x86_64 = kubeshark::https://github.com/kubeshark/kubeshark/releases/download/41.3/kubeshark_linux_amd64
+ sha256sums_x86_64 = 9f93bdd3779c8c809e5614f859c3f7e3c122101322f503b45551762905796526
+ source_aarch64 = kubeshark::https://github.com/kubeshark/kubeshark/releases/download/41.3/kubeshark_linux_arm64
+ sha256sums_aarch64 = e1547b68071603b6f308f2dd5098624e2283a4054d474841b77cf2d9cbff03ef
pkgname = kubeshark-bin
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..8eb231c8317a
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1 @@
+kubeshark*
diff --git a/.norelease b/.norelease
new file mode 100644
index 000000000000..e69de29bb2d1
--- /dev/null
+++ b/.norelease
diff --git a/PKGBUILD b/PKGBUILD
index cb6bfd5c486e..fc805c7e0cd8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,16 +1,33 @@
# Maintainer: Olivier Le Moal <mail at olivierlemoal dot fr>
+# Contributor: Vianney Bouchaud <aur dot vianney at bouchaud dot org>
pkgname=kubeshark-bin
+pkgdesc="Kubeshark is an API Traffic Analyzer for Kubernetes."
pkgver=41.3
-pkgrel=1
-pkgdesc="A simple-yet-powerful API traffic viewer for Kubernetes enabling you to view all API communication between microservices to help your debug and troubleshoot regressions."
-arch=('x86_64')
-conflicts=('mizu-bin')
+pkgrel=2
+arch=('x86_64' 'aarch64')
url="https://github.com/kubeshark/kubeshark"
-license=('Apache')
-source=("https://github.com/kubeshark/kubeshark/releases/download/${pkgver}/kubeshark_linux_amd64")
-sha256sums=('9f93bdd3779c8c809e5614f859c3f7e3c122101322f503b45551762905796526')
+license=('apache')
+conflicts=('kubeshark')
+provides=('kubeshark')
+
+sha256sums_x86_64=(
+ 9f93bdd3779c8c809e5614f859c3f7e3c122101322f503b45551762905796526
+)
+sha256sums_aarch64=(
+ e1547b68071603b6f308f2dd5098624e2283a4054d474841b77cf2d9cbff03ef
+)
+
+source_x86_64=(
+ "kubeshark::https://github.com/kubeshark/kubeshark/releases/download/${pkgver}/kubeshark_linux_amd64"
+)
+source_aarch64=(
+ "kubeshark::https://github.com/kubeshark/kubeshark/releases/download/${pkgver}/kubeshark_linux_arm64"
+)
package() {
- install -D -m755 kubeshark_linux_amd64 -T "${pkgdir}/usr/bin/kubeshark"
+ install -D -m0755 "${srcdir}/kubeshark" "${pkgdir}/usr/bin/kubeshark"
+
+ "${pkgdir}/usr/bin/kubeshark" completion bash | install -Dm644 /dev/stdin "${pkgdir}/usr/share/bash-completion/completions/kubeshark"
+ "${pkgdir}/usr/bin/kubeshark" completion zsh | install -Dm644 /dev/stdin "${pkgdir}/usr/share/zsh/site-functions/_kubeshark"
}