summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorToni Tauro2021-09-24 09:25:53 +0200
committerToni Tauro2021-09-24 09:25:53 +0200
commit3cc3d041b4615a8e1dd10e5e0588660d23c01abb (patch)
tree660061a4173e5e4e835b4e1390c34d2c2046f7f5
downloadaur-3cc3d041b4615a8e1dd10e5e0588660d23c01abb.tar.gz
init(kubeswitch): 0.4.7
Signed-off-by: Toni Tauro <eye@eyenx.ch>
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD18
2 files changed, 32 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..35c8afea9041
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = kubeswitch-bin
+ pkgdesc = The kubectx for operators.
+ pkgver = 0.4.7
+ pkgrel = 1
+ url = https://github.com/danielfoehrKn/kubeswitch
+ arch = x86_64
+ license = Apache
+ options = !strip
+ source = https://github.com/danielfoehrKn/kubeswitch/releases/download/0.4.7/switcher_linux_amd64
+ source = https://github.com/danielfoehrKn/kubeswitch/releases/download/0.4.7/switch.sh
+ sha256sums = a44f466dd9105f6366cd295eced390f5638b36656ccad51f2d7db9fa9133e3c0
+ sha256sums = 37484fb6ccd83ccf0e5b165a4ae04bfd107a510927e1c132310d01e2567fd78b
+
+pkgname = kubeswitch-bin
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..667955a2a6d5
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,18 @@
+# Maintainer: Toni Tauro <eye@eyenx.ch>
+# Co-Maintainer: Lukas Grossar <lukasgrossar@gmail.com>
+
+pkgname=kubeswitch-bin
+pkgver=0.4.7
+pkgrel=1
+pkgdesc="The kubectx for operators."
+arch=('x86_64')
+url="https://github.com/danielfoehrKn/kubeswitch"
+license=('Apache')
+source=("https://github.com/danielfoehrKn/kubeswitch/releases/download/${pkgver}/switcher_linux_amd64" "https://github.com/danielfoehrKn/kubeswitch/releases/download/${pkgver}/switch.sh")
+sha256sums=('a44f466dd9105f6366cd295eced390f5638b36656ccad51f2d7db9fa9133e3c0' '37484fb6ccd83ccf0e5b165a4ae04bfd107a510927e1c132310d01e2567fd78b')
+options=(!strip)
+
+package() {
+ install -Dm 755 "$srcdir/switcher_linux_amd64" "$pkgdir/usr/local/bin/switcher"
+ install -Dm 755 "$srcdir/switch.sh" "$pkgdir/usr/local/bin/switch.sh"
+}