summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLukas Grossar2023-01-09 10:45:18 +0100
committerLukas Grossar2023-01-09 10:51:10 +0100
commitb99e30a66929a126b066757c8c3a9cef6d05f28c (patch)
tree0ec37816100095c5a51f84494dd7eeece73aaf47
parent49c5ad0bf1ef704dcf642ea0b19b69c7fe4d75a3 (diff)
downloadaur-b99e30a66929a126b066757c8c3a9cef6d05f28c.tar.gz
Fix checksums again
I updated the sources to make sure that this error doesn't happen again in the future.
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD13
2 files changed, 12 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b4b99ff4c88c..5c884fe26ac4 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,14 @@
pkgbase = kubeswitch-bin
pkgdesc = The kubectx for operators.
pkgver = 0.7.2
- pkgrel = 2
+ pkgrel = 3
url = https://github.com/danielfoehrKn/kubeswitch
arch = x86_64
license = Apache
options = !strip
- source = https://github.com/danielfoehrKn/kubeswitch/releases/download/0.7.2/switcher_linux_amd64
- source = https://github.com/danielfoehrKn/kubeswitch/releases/download/0.7.2/switch.sh
- sha256sums = 17759a0e43d342716567f6ca602f3168efc8d1d036dbab79dfba2054d14b318c
- sha256sums = 93c131f9b8103604bd840d62cd2c5086be63da5454e73789e49bddf9f238088f
+ source = switcher_linux_amd64-0.7.2::https://github.com/danielfoehrKn/kubeswitch/releases/download/0.7.2/switcher_linux_amd64
+ source = switch.sh-0.7.2::https://github.com/danielfoehrKn/kubeswitch/releases/download/0.7.2/switch.sh
+ sha256sums = 24e8909aa5bd7ea8b1f486b46d1506ae6fcbcefe16d89c28884e9d217d8ada70
+ sha256sums = 9c01adbe98329cc43bf6e1832e6d98de934e368ca170ba8260ff710c826d4116
pkgname = kubeswitch-bin
diff --git a/PKGBUILD b/PKGBUILD
index 96e9aa359963..dee54d5aab9d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,17 +3,18 @@
pkgname=kubeswitch-bin
pkgver=0.7.2
-pkgrel=2
+pkgrel=3
pkgdesc="The kubectx for operators."
arch=('x86_64')
url="https://github.com/danielfoehrKn/kubeswitch"
license=('Apache')
-source=("https://github.com/danielfoehrKn/kubeswitch/releases/download/${pkgver}/switcher_linux_amd64" "https://github.com/danielfoehrKn/kubeswitch/releases/download/${pkgver}/switch.sh")
-sha256sums=('17759a0e43d342716567f6ca602f3168efc8d1d036dbab79dfba2054d14b318c'
- '93c131f9b8103604bd840d62cd2c5086be63da5454e73789e49bddf9f238088f')
+source=("switcher_linux_amd64-${pkgver}::https://github.com/danielfoehrKn/kubeswitch/releases/download/${pkgver}/switcher_linux_amd64"
+ "switch.sh-${pkgver}::https://github.com/danielfoehrKn/kubeswitch/releases/download/${pkgver}/switch.sh")
+sha256sums=('24e8909aa5bd7ea8b1f486b46d1506ae6fcbcefe16d89c28884e9d217d8ada70'
+ '9c01adbe98329cc43bf6e1832e6d98de934e368ca170ba8260ff710c826d4116')
options=(!strip)
package() {
- install -Dm 755 "$srcdir/switcher_linux_amd64" "$pkgdir/usr/bin/switcher"
- install -Dm 755 "$srcdir/switch.sh" "$pkgdir/usr/bin/switch.sh"
+ install -Dm 755 "$srcdir/switcher_linux_amd64-${pkgver}" "$pkgdir/usr/bin/switcher"
+ install -Dm 755 "$srcdir/switch.sh-${pkgver}" "$pkgdir/usr/bin/switch.sh"
}