summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJose Riha2021-07-05 09:16:02 +0200
committerJose Riha2021-07-05 09:16:02 +0200
commit751f3140fd8958df6423118295e58d52c843166a (patch)
treef28cdf96f1e194f304e7765385f3ec090705d94f
parent9b7c8d8ae29911f4858eb5f8afc38ff4835b71a6 (diff)
downloadaur-751f3140fd8958df6423118295e58d52c843166a.tar.gz
Update
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD32
-rw-r--r--allegro_aliases.patch11
3 files changed, 10 insertions, 47 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 92ca463ccdd9..c15832d51eff 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,19 +1,13 @@
-# Generated by mksrcinfo v8
-# Tue Jan 8 22:12:40 UTC 2019
pkgbase = kulic
pkgdesc = 2d shooting game
- pkgver = 1.1
- pkgrel = 5
+ pkgver = 1.1.64
+ pkgrel = 1
url = http://hippo.nipax.cz/download.cz.php?id=59
- arch = i686
arch = x86_64
license = GPL-2
depends = allegro4
depends = libjpeg
- source = http://hippo.nipax.cz/src/kulic-1.1.tar.gz
- source = allegro_aliases.patch
- md5sums = 16aff4bded3ae1c6712ca71d4d429730
- md5sums = 9671a62c0cab0b0b2e5106f80b43a921
+ source = http://hippo.nipax.cz/src/kulic-1.1.64.tar.gz
+ md5sums = c5a8271b4273afd4170df0ded82994e2
pkgname = kulic
-
diff --git a/PKGBUILD b/PKGBUILD
index 6f3fe4d9608f..495921123046 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,42 +1,22 @@
# Maintainer: jose <jose1711 [at] gmail (dot) com>
pkgname=kulic
-pkgver=1.1
-pkgrel=5
+pkgver=1.1.64
+pkgrel=1
pkgdesc="2d shooting game"
url='http://hippo.nipax.cz/download.cz.php?id=59'
-arch=('i686' 'x86_64')
+arch=('x86_64')
license=('GPL-2')
depends=('allegro4' 'libjpeg')
-source=("http://hippo.nipax.cz/src/${pkgname}-${pkgver}.tar.gz" "allegro_aliases.patch")
-md5sums=('16aff4bded3ae1c6712ca71d4d429730'
- '9671a62c0cab0b0b2e5106f80b43a921')
-
-prepare() {
- cd $srcdir/${pkgname}-${pkgver}
- patch -p0 -i $srcdir/allegro_aliases.patch
- mv configure.in configure.ac
-}
+source=("http://hippo.nipax.cz/src/${pkgname}-${pkgver}.tar.gz")
+md5sums=('c5a8271b4273afd4170df0ded82994e2')
build() {
cd $srcdir/${pkgname}-${pkgver}
- aclocal
- automake --add-missing
- autoconf
- ./configure --prefix=/usr
make
}
package() {
cd $srcdir/${pkgname}-${pkgver}
- make DESTDIR="$pkgdir/" install
- mv $pkgdir/usr/bin/kulic $pkgdir/usr/share/kulic
- ( echo "#!/bin/bash
-cd /usr/share/kulic
-padsp ./kulic" ) > $pkgdir/usr/bin/kulic
- chmod 755 $pkgdir/usr/bin/kulic
- cd misc
- install -D -m644 kulic.6 $pkgdir/usr/share/man/man6/kulic.6
- install -D -m644 kulic.xpm $pkgdir/usr/share/pixmaps/kulic.xpm
- install -D -m644 kulic.desktop $pkgdir/usr/share/applications/kulic.desktop
+ make DESTDIR="$pkgdir/usr" install
}
diff --git a/allegro_aliases.patch b/allegro_aliases.patch
deleted file mode 100644
index 50f3404e47fe..000000000000
--- a/allegro_aliases.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- acinclude.m4.old 2009-12-21 23:20:06.000000000 +0100
-+++ acinclude.m4 2019-01-08 22:28:36.983940138 +0100
-@@ -42,7 +42,7 @@
- if test "$ALLEGRO_CONFIG" = "no" ; then
- no_allegro=yes
- else
-- allegro_CFLAGS=`$ALLEGRO_CONFIG $ALLEGRO_CONFIG_args --cflags`
-+ allegro_CFLAGS=`$ALLEGRO_CONFIG $ALLEGRO_CONFIG_args --cflags`" -DALLEGRO_NO_FIX_ALIASES"
- allegro_LIBS=`$ALLEGRO_CONFIG $ALLEGRO_CONFIG_args --libs`
- ALLEGRO_CONFIG_major_version=`$ALLEGRO_CONFIG $ALLEGRO_CONFIG_args --version | \
- sed 's/\([[0-9]]*\).\([[0-9]]*\).\([[0-9]]*\)/\1/'`