summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJules P?nuchot2023-02-06 13:58:06 +0100
committerJules P?nuchot2023-02-06 13:58:06 +0100
commit946af7608775511538001c681db7a23f1252a8e5 (patch)
tree7df2b2163cb79761f7e9e670faea03cfb8930fed
downloadaur-946af7608775511538001c681db7a23f1252a8e5.tar.gz
kumi-git package creation
-rw-r--r--.SRCINFO16
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD36
3 files changed, 56 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..167401b9ed31
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = kumi-git
+ pkgdesc = C++20 Compact Tuple Tools
+ pkgver = v3.0.r9.g3cd97fa
+ pkgrel = 1
+ url = https://github.com/jfalcou/kumi
+ arch = any
+ license = Boost
+ makedepends = git
+ makedepends = cmake
+ makedepends = make
+ provides = kumi
+ conflicts = kumi
+ source = kumi-git::git+https://github.com/jfalcou/kumi.git#branch=main
+ sha256sums = SKIP
+
+pkgname = kumi-git
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..f71c635dafda
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*
+!.gitignore
+!PKGBUILD
+!.SRCINFO
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..23fbe4c71988
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,36 @@
+# Maintainer: Jules PĂ©nuchot <jules@penuchot.com>
+
+_name=kumi
+_author=jfalcou
+
+pkgname=${_name}-git
+pkgver=v3.0.r9.g3cd97fa
+pkgrel=1
+pkgdesc="C++20 Compact Tuple Tools"
+arch=('any')
+url="https://github.com/${_author}/${_name}"
+license=('Boost')
+
+depends=()
+makedepends=('git' 'cmake' 'make')
+provides=('kumi')
+conflicts=('kumi')
+
+source=("$pkgname::git+https://github.com/${_author}/${_name}.git#branch=main")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd $pkgname
+ git describe --long --tags --match 'v*' | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+prepare() {
+ cmake -B build -S ${pkgname} \
+ -DCMAKE_BUILD_TYPE:STRING='None' \
+ -DCMAKE_INSTALL_PREFIX:PATH='/usr' \
+ -Wno-dev
+}
+
+package() {
+ make -C build DESTDIR=$pkgdir install
+}