summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorVladislav Tyulbashev2015-06-30 21:16:53 +0300
committerVladislav Tyulbashev2015-06-30 21:16:53 +0300
commit6cad88d18c1bffefb6440ebf5f293144ec796280 (patch)
tree5cb84ad79c334eca0f15d1a91d8f59e467e49c18
downloadaur-6cad88d18c1bffefb6440ebf5f293144ec796280.tar.gz
Initial import
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD31
2 files changed, 44 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..71c744cb183b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = kumir2-git
+ pkgdesc = An educational programming language and IDE in Russian schools
+ pkgver = 19.03.2015
+ pkgrel = 2
+ url = http://lpm.org.ru/kumir
+ arch = x86_64
+ arch = i686
+ license = GPL2
+ depends = qt4
+ replaces = kumir
+
+pkgname = kumir2-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e6cff568c58d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: vtyulb <vtyulb@vtyulb.ru>
+
+pkgname=kumir2-git
+pkgver=19.03.2015
+pkgrel=2
+pkgdesc="An educational programming language and IDE in Russian schools"
+url="http://lpm.org.ru/kumir"
+arch=('x86_64' 'i686')
+license=('GPL2')
+depends=('qt4')
+replaces=("kumir")
+
+build() {
+ cd "${srcdir}"
+ git clone https://gitorious.org/kumir2/kumir2.git
+ cd "${srcdir}/kumir2"
+ cd src/plugins
+ cat CMakeLists.txt | grep -v "llvmcodegenerator" > CMakeLists1
+ mv CMakeLists1 CMakeLists.txt
+ cd ../..
+ mkdir build
+ cd build
+ cmake -DCMAKE_INSTALL_PREFIX="${pkgdir}/usr/" ../
+ make
+}
+
+package() {
+ cd "${srcdir}/kumir2/build"
+ make install
+ mv "${pkgdir}/usr/lib64" "${pkgdir}/usr/lib"
+}