summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorkyli0x2020-09-09 16:43:11 -0400
committerkyli0x2020-09-09 16:43:11 -0400
commit12f6c02662721c83f7ad17aeebd80ddb0bf93044 (patch)
tree4f8b66b20d9a20467e918be4180de2bf4df4391e
downloadaur-12f6c02662721c83f7ad17aeebd80ddb0bf93044.tar.gz
initial push
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD19
2 files changed, 34 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..8c89d64657d8
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = kurcoder-git
+ pkgdesc = Toolkit for encoding, decoding, checksums, hex conversions & IP calculations
+ pkgver = 0.0.1
+ pkgrel = 1
+ url = https://github.com/0xkurome/kurcoder
+ arch = any
+ license = MIT
+ makedepends = git
+ depends = python3
+ depends = python-pip
+ source = git+https://github.com/0xkurome/kurcoder
+ md5sums = SKIP
+
+pkgname = kurcoder-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6e95ef12225e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,19 @@
+# Maintainer: Your Name <kyli0x@protonmail.ch>
+
+pkgname=kurcoder-git
+pkgver=0.0.1
+pkgrel=1
+pkgdesc="Toolkit for encoding, decoding, checksums, hex conversions & IP calculations"
+arch=(any)
+url="https://github.com/0xkurome/kurcoder"
+license=('MIT')
+depends=('python3' 'python-pip')
+makedepends=('git')
+source=("git+$url")
+md5sums=('SKIP')
+
+
+package() {
+ cd "${pkgname%-git}"
+ python3 setup.py install --optimize="1" --root="$pkgdir"
+}