summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlexander Susha2018-02-12 12:06:16 +0300
committerAlexander Susha2018-02-12 12:06:16 +0300
commit0dacacf007973825205b1140e4a1271704908922 (patch)
treed4c7f417b8dbea8b2879c71c2b6e4407f0551da0
downloadaur-0dacacf007973825205b1140e4a1271704908922.tar.gz
Initial commit
-rw-r--r--.SRCINFO40
-rw-r--r--PKGBUILD38
-rw-r--r--kurento.conf.json.patch42
3 files changed, 120 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..9d0c98449796
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,40 @@
+pkgbase = kurento-media-server
+ pkgdesc = Kurento Media Server
+ pkgver = 6.6.2
+ pkgrel = 1
+ url = http://www.kurento.org/
+ arch = any
+ license = LGPL v2.1
+ makedepends = cmake
+ makedepends = gstreamer
+ makedepends = gst-plugins-base
+ makedepends = gst-plugins-good
+ makedepends = gst-plugins-bad
+ makedepends = gst-plugins-ugly
+ makedepends = gst-libav
+ makedepends = libsigc++
+ makedepends = glibmm
+ makedepends = kms-core
+ makedepends = kms-elements
+ makedepends = kms-filters
+ depends = boost-libs
+ depends = gstreamer
+ depends = gst-plugins-base
+ depends = gst-plugins-good
+ depends = gst-plugins-bad
+ depends = gst-plugins-ugly
+ depends = gst-libav
+ depends = libsigc++
+ depends = glibmm
+ depends = kms-core
+ depends = kms-elements
+ depends = kms-filters
+ provides = kurento-media-server
+ conflicts = kurento-media-server
+ source = https://github.com/Kurento/kurento-media-server/archive/6.6.2.tar.gz
+ source = kurento.conf.json.patch
+ sha256sums = cd1a6b3ce3fa869b58c4df4f307bf95e1dc7019c358097e9a7006e0e212c84b3
+ sha256sums = db711ae29c104d2b28744cc695c2f8bc4c185668a681c2972a9a07701796e7f2
+
+pkgname = kurento-media-server
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3663bd65a53b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,38 @@
+# Maintainer: Alexander Susha <isushik94@gmail.com>
+pkgname=kurento-media-server
+pkgver=6.6.2
+pkgrel=1
+pkgdesc='Kurento Media Server'
+arch=('any')
+url='http://www.kurento.org/'
+license=('LGPL v2.1')
+depends=('boost-libs' 'gstreamer' 'gst-plugins-base' 'gst-plugins-good' 'gst-plugins-bad' 'gst-plugins-ugly' 'gst-libav' 'libsigc++' 'glibmm' 'kms-core' 'kms-elements' 'kms-filters')
+makedepends=('cmake' 'gstreamer' 'gst-plugins-base' 'gst-plugins-good' 'gst-plugins-bad' 'gst-plugins-ugly' 'gst-libav' 'libsigc++' 'glibmm' 'kms-core' 'kms-elements' 'kms-filters')
+provides=(${pkgname})
+conflicts=(${pkgname})
+source=("https://github.com/Kurento/${pkgname}/archive/${pkgver}.tar.gz"
+ 'kurento.conf.json.patch')
+sha256sums=('cd1a6b3ce3fa869b58c4df4f307bf95e1dc7019c358097e9a7006e0e212c84b3'
+ 'db711ae29c104d2b28744cc695c2f8bc4c185668a681c2972a9a07701796e7f2')
+
+prepare(){
+ cd ${srcdir}/${pkgname}-${pkgver}
+
+ patch -Nu < ../kurento.conf.json.patch
+
+ for FILE in $(find . -type f)
+ do
+ sed -i -E "s/gstreamer\-((\w|\d)+\-)?1\.5/gstreamer-\11.0/g" $FILE
+ sed -i -E "s/SSL_R_SHORT_READ/boost::asio::ssl::error::stream_truncated/g" $FILE
+ done
+}
+build() {
+ mkdir -p "build"
+ cd "build"
+
+ cmake ${srcdir}/${pkgname}-${pkgver}/. -DCMAKE_BUILD_TYPE=RELEASE -DCMAKE_INSTALL_PREFIX=/usr -DCMAKE_INSTALL_LIBDIR=lib -DCMAKE_CXX_FLAGS="-Wno-deprecated-declarations"
+}
+package() {
+ make -C build DESTDIR="${pkgdir}" install
+ mv ${pkgdir}/usr/etc ${pkgdir}/
+}
diff --git a/kurento.conf.json.patch b/kurento.conf.json.patch
new file mode 100644
index 000000000000..7ea20a7e5f9f
--- /dev/null
+++ b/kurento.conf.json.patch
@@ -0,0 +1,42 @@
+--- kurento.conf.json 2018-02-06 10:19:47.246319048 +0300
++++ kurento.conf.json 2018-02-06 10:38:24.913381988 +0300
+@@ -1,25 +1,25 @@
+ {
+ "mediaServer" : {
+ "resources": {
+- // //Resources usage limit for raising an exception when an object creation is attempted
+- // "exceptionLimit": "0.8",
+- // // Resources usage limit for restarting the server when no objects are alive
+- // "killLimit": "0.7",
+- // Garbage collector period in seconds
++ "_comment01": "// //Resources usage limit for raising an exception when an object creation is attempted",
++ "_comment02": "// \"exceptionLimit\": \"0.8\"",
++ "_comment03": "// // Resources usage limit for restarting the server when no objects are alive",
++ "_comment04": "// \"killLimit\": \"0.7\"",
++ "_comment05": "// Garbage collector period in seconds",
+ "garbageCollectorPeriod": 240
+ },
+ "net" : {
+ "websocket": {
+ "port": 8888,
+- //"secure": {
+- // "port": 8433,
+- // "certificate": "defaultCertificate.pem",
+- // "password": ""
+- //},
+- //"registrar": {
+- // "address": "ws://localhost:9090",
+- // "localAddress": "localhost"
+- //},
++ "_comment01": "//\"secure\": {",
++ "_comment02": "// \"port\": 8433,",
++ "_comment03": "// \"certificate\": \"defaultCertificate.pem\",",
++ "_comment04": "// \"password\": \"\"",
++ "_comment05": "//},",
++ "_comment06": "//\"registrar\": {",
++ "_comment07": "// \"address\": \"ws://localhost:9090\"",
++ "_comment08": "// \"localAddress\": \"localhost\"",
++ "_comment09": "//}",
+ "path": "kurento",
+ "threads": 10
+ }