summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPaul Nicholson2018-07-12 20:48:27 -0700
committerPaul Nicholson2018-07-12 20:48:27 -0700
commit1fe206b067eb39e09578f4d3931b86a728cbb21c (patch)
treeff093e77cdb5d0e2816e6db27c1479bcbad99a46
downloadaur-1fe206b067eb39e09578f4d3931b86a728cbb21c.tar.gz
initial commit
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD18
2 files changed, 32 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e88cf9ebd104
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+# Generated by mksrcinfo v8
+# Fri Jul 13 03:48:06 UTC 2018
+pkgbase = kustomize-bin
+ pkgdesc = Customization of Kubernetes YAML configurations
+ pkgver = 1.0.3
+ pkgrel = 1
+ url = https://github.com/kubernetes-sigs/kustomize
+ arch = x86_64
+ license = Apache
+ source = https://github.com/kubernetes-sigs/kustomize/releases/download/v1.0.3/kustomize_1.0.3_linux_amd64
+ sha256sums = 13011de1e7d1f99cbdb3c74161519dd1079930bb20abc90f7bdac7e008774dc7
+
+pkgname = kustomize-bin
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a3682bf518d4
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,18 @@
+# $Id$
+# Contributor: Paul Nicholson <brenix@gmail.com>
+
+_name=kustomize
+pkgname=kustomize-bin
+pkgver=1.0.3
+pkgrel=1
+pkgdesc="Customization of Kubernetes YAML configurations"
+arch=('x86_64')
+url="https://github.com/kubernetes-sigs/kustomize"
+license=('Apache')
+source=("https://github.com/kubernetes-sigs/${_name}/releases/download/v${pkgver}/${_name}_${pkgver}_linux_amd64")
+sha256sums=('13011de1e7d1f99cbdb3c74161519dd1079930bb20abc90f7bdac7e008774dc7')
+
+package() {
+ cd "${srcdir}"
+ install -Dm755 ${_name}_${pkgver}_linux_amd64 ${pkgdir}/usr/bin/${_name}
+}