summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Bermond2019-06-09 16:23:14 +0000
committerDaniel Bermond2019-06-09 16:24:28 +0000
commit03444d1b8ceb6ab4804cb128e58275ac97e6ef04 (patch)
tree0f1f5ea05401d9b4d2b9abb68e9f8bed5314ea44
parentbbeea7b3159bc9311fd09f066d7fbbdd23071763 (diff)
downloadaur-03444d1b8ceb6ab4804cb128e58275ac97e6ef04.tar.gz
Remove i686. Remove so-provide. Do not rename clone dir. Add tests.
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD45
-rw-r--r--kvazaar-git-disable-test-external-symbols.patch18
3 files changed, 52 insertions, 23 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a5701c8f8111..2d1047a2d3b7 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,23 +1,25 @@
pkgbase = kvazaar-git
pkgdesc = An open-source HEVC encoder (git version)
- pkgver = 1.2.0.r71.g6be81959
+ pkgver = 1.2.0.r313.g933ff6ed
pkgrel = 1
url = http://ultravideo.cs.tut.fi/#encoder
- arch = i686
arch = x86_64
license = LGPL
+ checkdepends = ffmpeg
+ checkdepends = hm
makedepends = git
makedepends = yasm
depends = glibc
depends = gcc-libs
depends = crypto++
provides = kvazaar
- provides = libkvazaar.so
conflicts = kvazaar
- source = kvazaar-git::git+https://github.com/ultravideo/kvazaar.git
- source = kvazaar-submodule-greatest::git+https://github.com/ultravideo/greatest.git
+ source = git+https://github.com/ultravideo/kvazaar.git
+ source = git+https://github.com/ultravideo/greatest.git
+ source = kvazaar-git-disable-test-external-symbols.patch
sha256sums = SKIP
sha256sums = SKIP
+ sha256sums = 3a4dd1b38d58751381b24c81a86c21df7cfdc85ba5c6a13d879f112e463189b9
pkgname = kvazaar-git
diff --git a/PKGBUILD b/PKGBUILD
index 0581ccecbd93..756ab74966cc 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,55 +1,64 @@
-# Maintainer : Daniel Bermond < yahoo-com: danielbermond >
+# Maintainer : Daniel Bermond < gmail-com: danielbermond >
# Contributor: Devaux Fabien <fdev31@gmail.com>
pkgname=kvazaar-git
-pkgver=1.2.0.r71.g6be81959
+pkgver=1.2.0.r313.g933ff6ed
pkgrel=1
pkgdesc='An open-source HEVC encoder (git version)'
-arch=('i686' 'x86_64')
+arch=('x86_64')
url='http://ultravideo.cs.tut.fi/#encoder'
license=('LGPL')
depends=('glibc' 'gcc-libs' 'crypto++')
makedepends=('git' 'yasm')
-provides=('kvazaar' 'libkvazaar.so')
+checkdepends=('ffmpeg' 'hm')
+provides=('kvazaar')
conflicts=('kvazaar')
-source=("$pkgname"::'git+https://github.com/ultravideo/kvazaar.git'
- 'kvazaar-submodule-greatest'::'git+https://github.com/ultravideo/greatest.git')
+source=('git+https://github.com/ultravideo/kvazaar.git'
+ 'git+https://github.com/ultravideo/greatest.git'
+ 'kvazaar-git-disable-test-external-symbols.patch')
sha256sums=('SKIP'
- 'SKIP')
+ 'SKIP'
+ '3a4dd1b38d58751381b24c81a86c21df7cfdc85ba5c6a13d879f112e463189b9')
prepare() {
- cd "$pkgname"
+ cd kvazaar
git submodule init
- git config --local submodule.greatest.url "${srcdir}/kvazaar-submodule-greatest"
+ git config --local submodule.greatest.url "${srcdir}/greatest"
git submodule update
+
+ # disable a test that is failing: test_external_symbols.sh
+ # https://github.com/ultravideo/kvazaar/issues/215
+ patch -Np1 -i "${srcdir}/kvazaar-git-disable-test-external-symbols.patch"
+
+ ./autogen.sh
}
pkgver() {
- cd "$pkgname"
+ cd kvazaar
# git, tags available
git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g;s/^v//'
}
build() {
- cd "$pkgname"
-
- ./autogen.sh
+ cd kvazaar
./configure \
--prefix='/usr' \
- --enable-largefile \
- --enable-static='no' \
- --enable-shared='yes' \
- --enable-fast-install='yes' \
--with-cryptopp
make
}
+check() {
+ cd kvazaar
+
+ make check
+}
+
package() {
- cd "$pkgname"
+ cd kvazaar
make DESTDIR="$pkgdir" install
}
diff --git a/kvazaar-git-disable-test-external-symbols.patch b/kvazaar-git-disable-test-external-symbols.patch
new file mode 100644
index 000000000000..0abb82ec1990
--- /dev/null
+++ b/kvazaar-git-disable-test-external-symbols.patch
@@ -0,0 +1,18 @@
+diff -Naurp a/tests/Makefile.am b/tests/Makefile.am
+--- a/tests/Makefile.am 2019-06-05 00:24:38.000000000 +0000
++++ b/tests/Makefile.am 2019-06-05 00:25:15.735223946 +0000
+@@ -1,6 +1,5 @@
+
+ TESTS = $(check_PROGRAMS) \
+- test_external_symbols.sh \
+ test_gop.sh \
+ test_interlace.sh \
+ test_intra.sh \
+@@ -14,7 +13,6 @@ TESTS = $(check_PROGRAMS) \
+ test_weird_shapes.sh
+
+ EXTRA_DIST = \
+- test_external_symbols.sh \
+ test_gop.sh \
+ test_interlace.sh \
+ test_intra.sh \