summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Bermond2018-03-19 22:43:00 +0000
committerDaniel Bermond2018-03-19 22:43:00 +0000
commit230199b5b433f283807f6f388337d8990ffd881e (patch)
tree15ed2b4e4e96400598a828ce7fa4358bc3c688fd
parent001537d651b63d4c8cc6582fc661771d405b824b (diff)
downloadaur-230199b5b433f283807f6f388337d8990ffd881e.tar.gz
First commit after package adoption. Major rewrite.
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD94
2 files changed, 57 insertions, 54 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d0bcb7095685..ea2d411e205c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,23 @@
pkgbase = kvazaar-git
- pkgdesc = An open-source HEVC encoder
- pkgver = 0.8.3
+ pkgdesc = An open-source HEVC encoder licensed under LGPLv2.1 (git version)
+ pkgver = 1.2.0.r59.g01642916
pkgrel = 1
- url = https://github.com/ultravideo/kvazaar
+ url = http://ultravideo.cs.tut.fi/#encoder
arch = i686
arch = x86_64
- license = GPL2
+ license = LGPL2.1
makedepends = git
makedepends = yasm
+ depends = glibc
+ depends = gcc-libs
+ depends = crypto++
provides = kvazaar
+ provides = libkvazaar.so
+ conflicts = kvazaar
+ source = kvazaar-git::git+https://github.com/ultravideo/kvazaar.git
+ source = kvazaar-submodule-greatest::git+https://github.com/ultravideo/greatest.git
+ sha256sums = SKIP
+ sha256sums = SKIP
pkgname = kvazaar-git
diff --git a/PKGBUILD b/PKGBUILD
index d4cfb87906f5..52995a9a3c59 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,61 +1,55 @@
-# Maintainer: Devaux Fabien <fdev31@gmail.com>
+# Maintainer : Daniel Bermond < yahoo-com: danielbermond >
+# Contributor: Devaux Fabien <fdev31@gmail.com>
+
pkgname=kvazaar-git
-pkgver=0.8.3
+pkgver=1.2.0.r59.g01642916
pkgrel=1
-pkgdesc="An open-source HEVC encoder"
+pkgdesc='An open-source HEVC encoder licensed under LGPLv2.1 (git version)'
arch=('i686' 'x86_64')
-url="https://github.com/ultravideo/kvazaar"
-license=('GPL2')
-groups=()
-depends=()
+url='http://ultravideo.cs.tut.fi/#encoder'
+license=('LGPL2.1')
+depends=('glibc' 'gcc-libs' 'crypto++')
makedepends=('git' 'yasm')
-provides=('kvazaar')
-conflicts=()
-replaces=()
-backup=()
-options=()
-install=
-source=()
-noextract=()
-md5sums=() #generate with 'makepkg -g'
+provides=('kvazaar' 'libkvazaar.so')
+conflicts=('kvazaar')
+source=("$pkgname"::'git+https://github.com/ultravideo/kvazaar.git'
+ 'kvazaar-submodule-greatest'::'git+https://github.com/ultravideo/greatest.git')
+sha256sums=('SKIP'
+ 'SKIP')
+
+prepare() {
+ cd "$pkgname"
+
+ git submodule init
+ git config --local submodule.greatest.url "${srcdir}/kvazaar-submodule-greatest"
+ git submodule update
+}
-_gitroot=https://github.com/ultravideo/kvazaar.git
-_gitname=kvazaar
+pkgver() {
+ cd "$pkgname"
+
+ # git, tags available
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g;s/^v//'
+}
build() {
- cd "$srcdir"
- msg "Connecting to GIT server...."
-
- if [[ -d "$_gitname" ]]; then
- cd "$_gitname" && git pull origin
- msg "The local files are updated."
- else
- git clone "$_gitroot" "$_gitname"
- fi
-
- msg "GIT checkout done or server timeout"
- msg "Starting build..."
-
- rm -rf "$srcdir/$_gitname-build"
- git clone "$srcdir/$_gitname" "$srcdir/$_gitname-build"
- cd "$srcdir/$_gitname-build"
-
- #
- # BUILD HERE
- #
- ./autogen.sh
- ./configure --prefix=/usr/
- make
+ cd "$pkgname"
+
+ ./autogen.sh
+
+ ./configure \
+ --prefix='/usr' \
+ --enable-largefile \
+ --enable-static='no' \
+ --enable-shared='yes' \
+ --enable-fast-install='yes' \
+ --with-cryptopp
+
+ make
}
package() {
- cd "$srcdir/$_gitname-build"
- make DESTDIR="$pkgdir/" install
-
-# mkdir -p "$pkgdir/usr/bin"
-# mkdir -p "$pkgdir/usr/share/doc/$_gitname"
-# cp src/$_gitname "$pkgdir/usr/bin/"
-# cp README.md "$pkgdir/usr/share/doc/$_gitname/"
+ cd "$pkgname"
+
+ make DESTDIR="$pkgdir" install
}
-
-# vim:set ts=2 sw=2 et: