summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsmac892023-04-02 16:59:42 -0600
committersmac892023-04-02 16:59:42 -0600
commit21be2bb486d20db501b5888fea46dda2e52e86b1 (patch)
treecc22eda82df040af38f3d122d3a6f1dde703f2f4
downloadaur-21be2bb486d20db501b5888fea46dda2e52e86b1.tar.gz
create aur package v1.1
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD22
2 files changed, 36 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..2806c34002bc
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = kvkonqi
+ pkgdesc = A Kvantum theme that looks like Breeze theme
+ pkgver = 1.1
+ pkgrel = 1
+ url = https://github.com/Niru2169/KvKonqi
+ arch = any
+ license = GPL3
+ depends = kvantum-qt5
+ source = kvkonqi-dark@v1.1.tar.gz::https://github.com/Niru2169/KvKonqi/releases/download/v1.1/KvKonqiDark.tar.gz
+ source = kvkonqi-light@v1.1.tar.gz::https://github.com/Niru2169/KvKonqi/releases/download/v1.1/KvKonqiLight.tar.gz
+ sha256sums = 844fafaa191f641e64cab0ddf6b3434c62537145d48ef8c162dc85a64779e0b2
+ sha256sums = 1279c84c85a62ca614a0637b6467a2fa5b3d17d01fd4c19f67c4cb5408e126fa
+
+pkgname = kvkonqi
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e3df71e49444
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+# Maintainer: FirstAirBender <noblechuk5 at web dot de>
+
+_pkgname=KvKonqi
+pkgname=${_pkgname,,}
+pkgver=1.1
+pkgrel=1
+pkgdesc="A Kvantum theme that looks like Breeze theme"
+arch=('any')
+url="https://github.com/Niru2169/KvKonqi"
+license=('GPL3')
+depends=('kvantum-qt5')
+source=(
+ "$pkgname-dark@v${pkgver}.tar.gz::${url}/releases/download/v${pkgver}/${_pkgname}Dark.tar.gz"
+ "$pkgname-light@v${pkgver}.tar.gz::${url}/releases/download/v${pkgver}/${_pkgname}Light.tar.gz"
+)
+sha256sums=('844fafaa191f641e64cab0ddf6b3434c62537145d48ef8c162dc85a64779e0b2'
+ '1279c84c85a62ca614a0637b6467a2fa5b3d17d01fd4c19f67c4cb5408e126fa')
+
+package() {
+ install -dm755 $pkgdir/usr/share/Kvantum/
+ cp -R $srcdir/${_pkgname}{Dark,Light} -t $pkgdir/usr/share/Kvantum
+}