summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorepitron2017-03-01 04:28:23 -0500
committerepitron2017-03-01 04:28:23 -0500
commit794a4ffcecf4a47ed4e3d19fbca28fdf5f1206bc (patch)
treed2be3e480e83c44dd8fba03739f421f2d62fae12
downloadaur-794a4ffcecf4a47ed4e3d19fbca28fdf5f1206bc.tar.gz
First commit
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD43
2 files changed, 60 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..7f9f0456d7c8
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = kvmtool-git
+ pkgdesc = A lightweight (~5kloc) KVM-based virtual machine which can host Linux guests only
+ pkgver = 1573.3fea89a
+ pkgrel = 1
+ url = https://git.kernel.org/cgit/linux/kernel/git/will/kvmtool.git/
+ arch = i686
+ arch = x86_64
+ license = GPL2
+ makedepends = git
+ depends = binutils
+ source = kvmtool-git::git+https://git.kernel.org/pub/scm/linux/kernel/git/will/kvmtool.git
+ source = http://wiki.qemu.org/download/linux-0.2.img.bz2
+ sha256sums = SKIP
+ sha256sums = 41c222db3c669724dd202d2f0fe655ad88f847d8c263ed08bb90219082e7b423
+
+pkgname = kvmtool-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..fcb779a2cf35
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,43 @@
+# Maintainer: epitron <chris@ill-logic.com>
+
+pkgname=kvmtool-git
+pkgver=1573.3fea89a
+pkgrel=1
+pkgdesc="A lightweight (~5kloc) KVM-based virtual machine which can host Linux guests only"
+license=('GPL2')
+url="https://git.kernel.org/cgit/linux/kernel/git/will/kvmtool.git/"
+
+arch=('i686' 'x86_64') # add ARM support!
+depends=('binutils')
+makedepends=('git')
+
+source=(
+ ${pkgname}::git+https://git.kernel.org/pub/scm/linux/kernel/git/will/kvmtool.git
+ http://wiki.qemu.org/download/linux-0.2.img.bz2
+)
+
+sha256sums=(
+ SKIP
+ 41c222db3c669724dd202d2f0fe655ad88f847d8c263ed08bb90219082e7b423
+)
+
+pkgver() {
+ cd "$pkgname"
+ printf "%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd "$pkgname"
+
+ make
+}
+
+package() {
+ cd "$pkgname"
+
+ install -Dm 755 lkvm -t "${pkgdir}/usr/bin"
+ install -Dm 644 README ../linux-0.2.img -t "${pkgdir}/usr/share/kvmtool"
+
+ cd "${pkgdir}/usr/bin"
+ # ln -s lkvm vm
+}