summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Landau2015-06-27 17:59:39 +0300
committerDaniel Landau2015-06-27 17:59:39 +0300
commit3b9368fd43d6e82954cc3ae5b220905bf79a30b6 (patch)
treefcd30e9fd09fb68037841c660fb483b0352fa093
downloadaur-3b9368fd43d6e82954cc3ae5b220905bf79a30b6.tar.gz
Initial migration from old AUR
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD35
-rw-r--r--kvpm.install13
3 files changed, 69 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f7298d791c53
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+# Generated by makepkg 4.2.0
+# Sun Jan 11 13:59:50 UTC 2015
+pkgbase = kvpm
+ pkgdesc = Front end for Linux LVM and Gnu parted. It also handles creating and mounting file systems
+ pkgver = 0.9.9
+ pkgrel = 1
+ url = http://sourceforge.net/projects/kvpm/
+ install = kvpm.install
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = cmake
+ makedepends = automoc4
+ depends = parted
+ depends = kdebase-runtime
+ depends = lvm2>=2.02.98
+ source = http://downloads.sourceforge.net/project/kvpm/kvpm-0.9.9.tar.gz
+ sha256sums = 97f4a2f0632f9df7a9e3731c93088ba0725d942838603cdb4a4cba53c1c02604
+
+pkgname = kvpm
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3b3fdc320d8e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer: Daniel Landau <daniel.landau@iki.fi>
+# Contributor: Artem Sereda <overmind88@gmail.com>
+
+pkgname=kvpm
+pkgver=0.9.9
+# _pkgver=pl1
+pkgrel=1
+pkgdesc="Front end for Linux LVM and Gnu parted. It also handles creating and mounting file systems"
+arch=('i686' 'x86_64')
+url="http://sourceforge.net/projects/kvpm/"
+license=('GPL')
+depends=('parted' 'kdebase-runtime' 'lvm2>=2.02.98')
+makedepends=('cmake' 'automoc4')
+sha256sums=('97f4a2f0632f9df7a9e3731c93088ba0725d942838603cdb4a4cba53c1c02604')
+install=$pkgname.install
+# source=(http://downloads.sourceforge.net/${pkgname}/${pkgname}-${pkgver}-${_pkgver}.tar.gz)
+source=(http://downloads.sourceforge.net/project/${pkgname}/${pkgname}-${pkgver}.tar.gz)
+
+build () {
+ # cd ${srcdir}/${pkgname}-${pkgver}-${_pkgver}
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ sed -i'' -e 's/SBIN/BIN/' kvpm/CMakeLists.txt
+ mkdir -p build
+ cd build
+ cmake -DKDE4_ENABLE_HTMLHANDBOOK=OFF \
+ -DCMAKE_INSTALL_PREFIX=`kde4-config --prefix` \
+ -DCMAKE_BUILD_TYPE=Release ..
+ make || return 1
+}
+package () {
+ # cd ${srcdir}/${pkgname}-${pkgver}-${_pkgver}/build
+ cd "${srcdir}/${pkgname}-${pkgver}/build"
+ make DESTDIR=${pkgdir} install
+}
+
diff --git a/kvpm.install b/kvpm.install
new file mode 100644
index 000000000000..64d482e2428e
--- /dev/null
+++ b/kvpm.install
@@ -0,0 +1,13 @@
+pkgname=kvpm
+
+post_install() {
+ xdg-icon-resource forceupdate
+}
+
+post_upgrade() {
+ post_install $1
+}
+
+post_remove() {
+ xdg-icon-resource forceupdate
+}