summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlexKurisu2022-02-16 07:00:21 +0300
committerAlexKurisu2022-02-16 07:00:21 +0300
commit5fab6ed09df38dbb566ec01be0e828271bf9462d (patch)
tree1478d601fda6fa65d074300ee6eda4346bae58d7
parent373a5815047cd1a245040954a13f2bdc9bc34b40 (diff)
downloadaur-5fab6ed09df38dbb566ec01be0e828271bf9462d.tar.gz
Update to 5.91.0, remove cmake.patch
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD14
-rw-r--r--cmake.patch11
3 files changed, 12 insertions, 26 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 63d62615731e..83f9b7d0dabb 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = kwallet-secrets
pkgdesc = Secure and unified container for user passwords. Patched for org.freedesktop.secrets support
- pkgver = 5.90.0
- pkgrel = 2
+ pkgver = 5.91.0
+ pkgrel = 1
url = https://community.kde.org/Frameworks
arch = x86_64
groups = kf5
@@ -21,14 +21,13 @@ pkgbase = kwallet-secrets
provides = org.freedesktop.secrets
provides = kwallet
conflicts = kwallet
- source = https://download.kde.org/stable/frameworks/5.90/kwallet-5.90.0.tar.xz
- source = https://download.kde.org/stable/frameworks/5.90/kwallet-5.90.0.tar.xz.sig
+ options = debug
+ source = https://download.kde.org/stable/frameworks/5.91/kwallet-5.91.0.tar.xz
+ source = https://download.kde.org/stable/frameworks/5.91/kwallet-5.91.0.tar.xz.sig
source = https://invent.kde.org/frameworks/kwallet/-/merge_requests/11.patch
- source = cmake.patch
validpgpkeys = 53E6B47B45CEA3E0D5B7457758D0EE648A48B3BB
- sha256sums = 74aa1144a358a1a43a133dabf1b0936ae01dc290e585573dec88e52d097ace19
+ sha256sums = 3736051cfc42598368704b36c36f41482f778c45ba22a4e591389725945938fc
sha256sums = SKIP
sha256sums = 87455cec3a1221ce9e9cee85b92be58b51b1e70126d93f275f22e08bb2050834
- sha256sums = 18010e9d2ee0985749ac5a3090ff6bd8724bc2024132b36d9f7f2072f91fec4d
pkgname = kwallet-secrets
diff --git a/PKGBUILD b/PKGBUILD
index 037f2453e5fe..58ee042d6f3a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,8 +4,8 @@
o_pkgname=kwallet
pkgname=kwallet-secrets
-pkgver=5.90.0
-pkgrel=2
+pkgver=5.91.0
+pkgrel=1
pkgdesc='Secure and unified container for user passwords. Patched for org.freedesktop.secrets support'
arch=(x86_64)
url='https://community.kde.org/Frameworks'
@@ -18,17 +18,15 @@ provides=(org.freedesktop.secrets kwallet)
conflicts=(kwallet)
groups=(kf5)
source=(https://download.kde.org/stable/frameworks/${pkgver%.*}/$o_pkgname-$pkgver.tar.xz{,.sig}
- https://invent.kde.org/frameworks/kwallet/-/merge_requests/11.patch
- cmake.patch)
-sha256sums=('74aa1144a358a1a43a133dabf1b0936ae01dc290e585573dec88e52d097ace19'
+ https://invent.kde.org/frameworks/kwallet/-/merge_requests/11.patch)
+sha256sums=('3736051cfc42598368704b36c36f41482f778c45ba22a4e591389725945938fc'
'SKIP'
- '87455cec3a1221ce9e9cee85b92be58b51b1e70126d93f275f22e08bb2050834'
- '18010e9d2ee0985749ac5a3090ff6bd8724bc2024132b36d9f7f2072f91fec4d')
+ '87455cec3a1221ce9e9cee85b92be58b51b1e70126d93f275f22e08bb2050834')
validpgpkeys=(53E6B47B45CEA3E0D5B7457758D0EE648A48B3BB) # David Faure <faure@kde.org>
+options=(debug)
prepare() {
cd "$o_pkgname-$pkgver"
- patch -Np1 -i "${srcdir}/cmake.patch" # patch by HurricanePootis <hurricanepootis@protonmail.com>
patch -Np1 -i "${srcdir}/11.patch"
}
diff --git a/cmake.patch b/cmake.patch
deleted file mode 100644
index 2529feb005ac..000000000000
--- a/cmake.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- a/src/runtime/kwalletd/backend/CMakeLists.txt 2022-02-08 21:52:08.823207972 -0600
-+++ b/src/runtime/kwalletd/backend/CMakeLists.txt 2022-02-08 21:53:17.571101142 -0600
-@@ -56,7 +56,7 @@
-
- ecm_setup_version(${KF_VERSION} VARIABLE_PREFIX KWALLETBACKEND SOVERSION 5)
-
--target_link_libraries(kwalletbackend5 Qt5::Widgets KF5::WidgetsAddons KF5::CoreAddons KF5::Notifications KF5::I18n ${LIBGCRYPT_LIBRARIES})
-+target_link_libraries(kwalletbackend5 Qt${QT_MAJOR_VERSION}::Widgets KF5::WidgetsAddons KF5::CoreAddons KF5::Notifications KF5::I18n ${LIBGCRYPT_LIBRARIES})
- if(Gpgmepp_FOUND)
- target_link_libraries(kwalletbackend5 Gpgmepp)
- endif(Gpgmepp_FOUND)