summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJoão Figueiredo2021-05-30 18:57:38 +0100
committerJoão Figueiredo2021-05-30 18:57:38 +0100
commit8c1ae667e746b6b3b260ba3ee8af92e2abfb5bfe (patch)
treef48ded1344690e3fb5d1ede7190fc47d9a24d586
parentdf159987df07f7a4a60d57a134910b2b90bb8683 (diff)
downloadaur-8c1ae667e746b6b3b260ba3ee8af92e2abfb5bfe.tar.gz
Initial automated PKGBUILD update
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD8
2 files changed, 5 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e9de07f88a84..b3080f43e025 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = kwayland-git
pkgdesc = Qt-style Client and Server library wrapper for the Wayland libraries
- pkgver = 5.79.0_r1052.gba6115e
+ pkgver = 5.83.0_r1086.g8bc536d
pkgrel = 1
url = https://www.kde.org
arch = x86_64
@@ -10,7 +10,6 @@ pkgbase = kwayland-git
makedepends = extra-cmake-modules-git
makedepends = doxygen
makedepends = qt5-tools
- makedepends = qt5-doc
makedepends = wayland-protocols
makedepends = plasma-wayland-protocols-git
depends = qt5-wayland
diff --git a/PKGBUILD b/PKGBUILD
index 499440aed0be..ae770219630b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,16 +1,16 @@
# Merged with official ABS kwayland PKGBUILD by João, 2021/02/01 (all respective contributors apply herein)
-# Maintainer: João Figueiredo <jf.mundox@gmail.com>
+# Maintainer: João Figueiredo & chaotic-aur <islandc0der@chaotic.cx>
# Contributor: Antonio Rojas
pkgname=kwayland-git
-pkgver=5.79.0_r1052.gba6115e
+pkgver=5.83.0_r1086.g8bc536d
pkgrel=1
pkgdesc='Qt-style Client and Server library wrapper for the Wayland libraries'
arch=($CARCH)
url='https://www.kde.org'
license=(LGPL)
depends=(qt5-wayland)
-makedepends=(git extra-cmake-modules-git doxygen qt5-tools qt5-doc wayland-protocols plasma-wayland-protocols-git)
+makedepends=(git extra-cmake-modules-git doxygen qt5-tools wayland-protocols plasma-wayland-protocols-git)
conflicts=(${pkgname%-git})
provides=(${pkgname%-git})
groups=(kf5-git)
@@ -19,7 +19,7 @@ sha256sums=('SKIP')
pkgver() {
cd ${pkgname%-git}
- _ver="$(grep -m1 "set(KF5\?_VERSION" CMakeLists.txt | cut -d '"' -f2 | tr - .)"
+ _ver="$(grep -m1 'set(KF5\?_VERSION' CMakeLists.txt | cut -d '"' -f2 | tr - .)"
echo "${_ver}_r$(git rev-list --count HEAD).g$(git rev-parse --short HEAD)"
}