summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorStMartin812020-11-12 13:24:10 +0100
committerStMartin812020-11-12 13:24:10 +0100
commit46fd2a420c3917e6546f96c4cf636d7f26792c6a (patch)
treea30ea132946edc799fe65a2d32dd046ba5efb0fd
downloadaur-46fd2a420c3917e6546f96c4cf636d7f26792c6a.tar.gz
Initial commit
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD33
2 files changed, 53 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..598736a8bff9
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = kwayland-integration-git
+ pkgdesc = Provides integration plugins for various KDE frameworks for the wayland windowing system
+ pkgver = 5.20.3
+ pkgrel = 1
+ url = https://www.kde.org/workspaces/plasmadesktop/
+ arch = x86_64
+ groups = plasma
+ license = LGPL
+ makedepends = extra-cmake-modules
+ depends = kwindowsystem
+ depends = kidletime
+ depends = kwayland
+ depends = kguiaddons
+ provides = kwayland-integration
+ conflicts = kwayland-integration
+ source = git+https://invent.kde.org/plasma/kwayland-integration.git
+ sha256sums = SKIP
+
+pkgname = kwayland-integration-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..07dcf115c453
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer:Martin Stolpe <martin dot stolpe at gmail dot com>
+# Contributor:Antonio Rojas <arojas@archlinux.org>
+
+_pkgname=kwayland-integration
+pkgname=kwayland-integration-git
+pkgver=5.20.3
+pkgrel=1
+pkgdesc='Provides integration plugins for various KDE frameworks for the wayland windowing system'
+arch=(x86_64)
+url='https://www.kde.org/workspaces/plasmadesktop/'
+license=(LGPL)
+depends=(kwindowsystem kidletime kwayland kguiaddons)
+makedepends=(extra-cmake-modules)
+groups=(plasma)
+conflicts=(kwayland-integration)
+provides=(kwayland-integration)
+source=("git+https://invent.kde.org/plasma/$_pkgname.git")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd $srcdir/$_pkgname
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cmake -B build -S cd $srcdir/$_pkgname \
+ -DBUILD_TESTING=OFF
+ cmake --build build
+}
+
+package() {
+ DESTDIR="$pkgdir" cmake --install build
+}