summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorzan2020-07-18 00:39:17 -0400
committerzan2020-07-18 00:39:17 -0400
commit39025912359fa9f1dd2045553a90916c7b0cbaf5 (patch)
tree0961f8ee7a35189826c9202a3462c496d82c3fa4
downloadaur-39025912359fa9f1dd2045553a90916c7b0cbaf5.tar.gz
initial
-rw-r--r--.SRCINFO23
-rw-r--r--PKGBUILD35
2 files changed, 58 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b2da7feda129
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+pkgbase = kwayland-server-git
+ pkgdesc = Wayland Server Components built on KDE Frameworks
+ pkgver = v5.19.1.r65.g8351f51
+ pkgrel = 1
+ url = https://invent.kde.org/plasma/kwayland-server
+ arch = x86_64
+ groups = plasma
+ license = LGPL
+ makedepends = git
+ makedepends = extra-cmake-modules-git
+ makedepends = plasma-wayland-protocols
+ makedepends = wayland-protocols
+ makedepends = kwayland
+ makedepends = doxygen
+ makedepends = qt5-tools
+ depends = qt5-base
+ provides = kwayland-server
+ conflicts = kwayland-server
+ source = git+https://invent.kde.org/plasma/kwayland-server.git
+ md5sums = SKIP
+
+pkgname = kwayland-server-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7327a72f2a4e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer: zan <zan@420blaze.it>
+
+pkgname=kwayland-server-git
+_name=${pkgname%-git}
+pkgver=v5.19.1.r65.g8351f51
+pkgrel=1
+pkgdesc='Wayland Server Components built on KDE Frameworks '
+arch=(x86_64)
+url='https://invent.kde.org/plasma/kwayland-server'
+license=(LGPL)
+depends=(qt5-base)
+makedepends=(git extra-cmake-modules-git plasma-wayland-protocols wayland-protocols kwayland doxygen qt5-tools)
+conflicts=(kwayland-server)
+provides=(kwayland-server)
+groups=(plasma)
+source=("git+https://invent.kde.org/plasma/$_name.git")
+md5sums=('SKIP')
+
+pkgver() {
+ cd $_name
+ git describe --long | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ cmake -B build -S $_name
+ cmake --build build
+}
+
+package() {
+ DESTDIR="$pkgdir" cmake --install build
+}
+
+
+
+