summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorgustawho2021-03-03 14:33:52 -0700
committergustawho2021-03-03 14:33:52 -0700
commit0b235409d47bdd546828fcd022fca9a6bcf90cd1 (patch)
treefa0ca43f7c7b16def51f011f9529c4123c1c3f4b
downloadaur-0b235409d47bdd546828fcd022fca9a6bcf90cd1.tar.gz
Package added
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD22
2 files changed, 43 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..2b63e39e57f4
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = kweather
+ pkgdesc = Weather application for Plasma Mobile
+ pkgver = 0.4
+ pkgrel = 1
+ url = https://invent.kde.org/plasma-mobile/kweather
+ arch = x86_64
+ license = GPL3
+ makedepends = extra-cmake-modules
+ makedepends = qt5-tools
+ depends = ki18n
+ depends = kconfig
+ depends = kcoreaddons
+ depends = knotifications
+ depends = kirigami2
+ depends = kdbusaddons
+ depends = plasma-framework
+ source = https://invent.kde.org/plasma-mobile/kweather/-/archive/0.4/kweather-0.4.tar.gz
+ sha256sums = 94db92197a871d32a64117a4639e905f874f65f64e8975bf92c32f3fd31c70bd
+
+pkgname = kweather
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..cba75d008df8
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+# Maintainer: Gustavo Castro < gustawho [ at ] gmail [ dot ] com >
+
+pkgname=kweather
+pkgver=0.4
+pkgrel=1
+pkgdesc="Weather application for Plasma Mobile"
+arch=(x86_64)
+url="https://invent.kde.org/plasma-mobile/kweather"
+license=(GPL3)
+depends=(ki18n kconfig kcoreaddons knotifications kirigami2 kdbusaddons plasma-framework)
+makedepends=(extra-cmake-modules qt5-tools)
+source=("https://invent.kde.org/plasma-mobile/${pkgname}/-/archive/${pkgver}/${pkgname}-${pkgver}.tar.gz")
+sha256sums=('94db92197a871d32a64117a4639e905f874f65f64e8975bf92c32f3fd31c70bd')
+
+build() {
+ cmake -DCMAKE_INSTALL_PREFIX=/usr -B build -S "${pkgname}-${pkgver}"
+ make -C build
+}
+
+package() {
+ make -C build DESTDIR="${pkgdir}" PREFIX=/usr install
+}