summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorgustawho2022-07-01 23:57:16 -0600
committergustawho2022-07-01 23:57:16 -0600
commit35d0c8859c613c92c8492cb928fde2a697e96bfb (patch)
tree1d108cdc59b442fe8d685a00e6e078053cb9a8b7
parent8e832c652e0d9a3d26ea88e8c2bb5a750c73c5af (diff)
downloadaur-35d0c8859c613c92c8492cb928fde2a697e96bfb.tar.gz
PKGBUILD format
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD8
2 files changed, 5 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ba06a936f6ec..9c39a40aacf1 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = kweathercore-git
pkgdesc = Library to facilitate retrieval of weather information including forecasts and alerts
- pkgver = v21.05.r4.gca67d2c
+ pkgver = 0.6.r3.g405594f
pkgrel = 1
url = https://invent.kde.org/libraries/kweathercore
arch = x86_64
@@ -21,4 +21,3 @@ pkgbase = kweathercore-git
sha256sums = SKIP
pkgname = kweathercore-git
-
diff --git a/PKGBUILD b/PKGBUILD
index 03d3b36ca8df..3888ba4d0e6e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Gustavo Castro < gustawho [ at ] gmail [ dot ] com >
pkgname=kweathercore-git
-pkgver=v21.05.r4.gca67d2c
+pkgver=0.6.r3.g405594f
pkgrel=1
pkgdesc="Library to facilitate retrieval of weather information including forecasts and alerts"
arch=(x86_64 i686 arm armv6h armv7h aarch64)
@@ -17,8 +17,8 @@ sha256sums=('SKIP')
pkgver() {
cd "${pkgname%-git}"
( set -o pipefail
- git describe --long 2>/dev/null | sed 's/\([^-]*-g\)/r\1/;s/-/./g' ||
- printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ git describe --long --tags --first-parent --match 'v[0-9][0-9.][0-9.]*' | \
+ sed 's=^v==;s=^\([0-9][0-9.]*\)-\([a-zA-Z]\+\)=\1\2=;s=\([0-9]\+-g\)=r\1=;s=-=.=g'
)
}
@@ -29,4 +29,4 @@ build() {
package() {
DESTDIR="${pkgdir}" cmake --install build --config RelWithDebInfo
-} \ No newline at end of file
+}