summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorgustawho2021-05-13 20:50:35 -0600
committergustawho2021-05-13 20:50:35 -0600
commit8e832c652e0d9a3d26ea88e8c2bb5a750c73c5af (patch)
treebde8e04e13977c09feefad0d5c715bd49666d6d8
parentc756febf85f60ddeea6387360b73ad06feb870b6 (diff)
downloadaur-8e832c652e0d9a3d26ea88e8c2bb5a750c73c5af.tar.gz
PKGBUILD cleanup
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD14
2 files changed, 14 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f0370ac183d8..ba06a936f6ec 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,18 @@
pkgbase = kweathercore-git
pkgdesc = Library to facilitate retrieval of weather information including forecasts and alerts
- pkgver = release.0.1.1.r2.g7e84fac
+ pkgver = v21.05.r4.gca67d2c
pkgrel = 1
url = https://invent.kde.org/libraries/kweathercore
arch = x86_64
+ arch = i686
+ arch = arm
+ arch = armv6h
+ arch = armv7h
+ arch = aarch64
license = GPL3
makedepends = git
makedepends = extra-cmake-modules
+ makedepends = qt5-tools
depends = ki18n
depends = qt5-location
provides = kweathercore
diff --git a/PKGBUILD b/PKGBUILD
index 9a0f289adf7c..03d3b36ca8df 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,14 +1,14 @@
# Maintainer: Gustavo Castro < gustawho [ at ] gmail [ dot ] com >
pkgname=kweathercore-git
-pkgver=release.0.1.1.r2.g7e84fac
+pkgver=v21.05.r4.gca67d2c
pkgrel=1
pkgdesc="Library to facilitate retrieval of weather information including forecasts and alerts"
-arch=(x86_64)
+arch=(x86_64 i686 arm armv6h armv7h aarch64)
url="https://invent.kde.org/libraries/kweathercore"
license=(GPL3)
depends=('ki18n' 'qt5-location')
-makedepends=('git' 'extra-cmake-modules')
+makedepends=('git' 'extra-cmake-modules' 'qt5-tools')
provides=('kweathercore')
conflicts=('kweathercore')
source=("git+${url}.git")
@@ -23,10 +23,10 @@ pkgver() {
}
build() {
- cmake -DCMAKE_INSTALL_PREFIX=/usr -B build -S "${pkgname%-git}"
- make -C build
+ cmake -DCMAKE_INSTALL_PREFIX=/usr -DCMAKE_BUILD_TYPE=RelWithDebInfo -B build -S "${pkgname%-git}"
+ cmake --build build --config RelWithDebInfo
}
package() {
- make -C build DESTDIR="${pkgdir}" PREFIX=/usr install
-}
+ DESTDIR="${pkgdir}" cmake --install build --config RelWithDebInfo
+} \ No newline at end of file