summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDavid Strobach2018-08-12 04:29:20 +0200
committerDavid Strobach2018-08-12 04:29:20 +0200
commit86eeeaca28e443009a842dbae408d68d69b1eb19 (patch)
treeee8d685fe736981fd9bcb558729aebb5ef68ad5b
downloadaur-86eeeaca28e443009a842dbae408d68d69b1eb19.tar.gz
Let there be git
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD43
2 files changed, 58 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..0bdeec066f3f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = kwin-effect-osdclock-git
+ pkgdesc = KWin effect that displays clock at the corner the screen
+ pkgver = 20180812.594e4de
+ pkgrel = 1
+ url = https://github.com/laloch/kwin-effect-osdclock
+ arch = x86_64
+ license = GPL
+ makedepends = extra-cmake-modules
+ makedepends = git
+ depends = kwin
+ source = kwin-effect-osdclock::git+http://github.com/laloch/kwin-effect-osdclock.git
+ md5sums = SKIP
+
+pkgname = kwin-effect-osdclock-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..282546c84a3a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,43 @@
+# Maintainer: laloch <lalochcz@gmail.com>
+
+_pkgname=kwin-effect-osdclock
+pkgname="$_pkgname-git"
+pkgver=20180812.594e4de
+pkgrel=1
+pkgdesc='KWin effect that displays clock at the corner the screen'
+arch=('x86_64')
+url="https://github.com/laloch/${_pkgname}"
+license=('GPL')
+depends=('kwin')
+makedepends=('extra-cmake-modules' 'git')
+source=("$_pkgname"::"git+http://github.com/laloch/${_pkgname}.git")
+md5sums=('SKIP')
+
+pkgver() {
+ cd $_pkgname
+ echo "$(git log -1 --format="%cd" --date=short | tr -d '-').$(git log -1 --format="%h")"
+}
+
+prepare() {
+ cd $_pkgname
+ mkdir -p build
+}
+
+build(){
+ cd $_pkgname
+ cd build
+ cmake .. \
+ -DCMAKE_C_FLAGS:STRING="" \
+ -DCMAKE_CXX_FLAGS:STRING="" \
+ -DCMAKE_EXE_LINKER_FLAGS:STRING="" \
+ -DCMAKE_SHARED_LINKER_FLAGS:STRING="" \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_INSTALL_LIBDIR=lib
+ make
+}
+
+package(){
+ cd $_pkgname
+ cd build
+ make DESTDIR="$pkgdir" install
+}