summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorxiota2023-04-09 00:07:53 -0700
committerxiota2023-04-09 00:07:53 -0700
commit469b9d7ed57ebc9fcf382576404b239847023d65 (patch)
treebc68cc8820c6ca736ea7bc5d82a8502d293e6fd1
downloadaur-469b9d7ed57ebc9fcf382576404b239847023d65.tar.gz
Initial commit
-rw-r--r--.SRCINFO21
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD59
3 files changed, 84 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..5cffca55f73e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = kwin-effect-rounded-corners-git
+ pkgdesc = Rounds the corners of your windows
+ pkgver = r223.28855e8
+ pkgrel = 1
+ url = https://github.com/matinlotfali/KDE-Rounded-Corners
+ arch = x86_64
+ license = GPL3
+ makedepends = cmake
+ makedepends = extra-cmake-modules
+ makedepends = git
+ makedepends = kinit
+ makedepends = qt5-tools
+ depends = kwin
+ provides = kde-rounded-corners
+ provides = kwin-effect-rounded-corners
+ conflicts = kde-rounded-corners
+ conflicts = kwin-effect-rounded-corners
+ source = kde-rounded-corners::git+https://github.com/matinlotfali/KDE-Rounded-Corners
+ sha512sums = SKIP
+
+pkgname = kwin-effect-rounded-corners-git
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..018a3de08144
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*
+!PKGBUILD
+!.SRCINFO
+!.gitignore
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6ae2b2232e7a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,59 @@
+# Contributor: 2xsaiko <aur@dblsaiko.net>
+
+_gitname="kde-rounded-corners"
+_pkgname="kwin-effect-rounded-corners"
+pkgname="$_pkgname-git"
+pkgver=r223.28855e8
+pkgrel=1
+pkgdesc="Rounds the corners of your windows"
+arch=('x86_64')
+url="https://github.com/matinlotfali/KDE-Rounded-Corners"
+license=("GPL3")
+provides=(
+ "$_gitname"
+ "$_pkgname"
+)
+conflicts=(${provides[@]})
+depends=(
+ 'kwin'
+)
+makedepends=(
+ 'cmake'
+ 'extra-cmake-modules'
+ 'git'
+ 'kinit'
+ 'qt5-tools'
+)
+
+source=(
+ "$_gitname"::"git+$url"
+)
+sha512sums=(
+ "SKIP"
+)
+
+pkgver() {
+ cd "$srcdir/$_gitname"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+prepare() {
+ mkdir -p qt5build
+}
+
+build() {
+ cd qt5build
+ cmake "../$_gitname" \
+ -DCMAKE_INSTALL_PREFIX='/usr/lib/qt/plugins/' \
+ -DQT5BUILD=ON
+ make
+}
+
+package() {
+ cd qt5build
+ make DESTDIR="$pkgdir" install
+
+ # fix file locations
+ mkdir -p "$pkgdir/usr/lib/qt/plugins"
+ mv "$pkgdir/kwin" "$pkgdir/usr/lib/qt/plugins/"
+}