summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorVlad Zagorodniy2018-05-06 20:01:59 +0300
committerVlad Zagorodniy2018-05-06 20:01:59 +0300
commit3f4a911deb12fcefcf98dc7cc40f2b27036cf3c6 (patch)
tree6932c3a89a3afbc5cc36df35c89ca07f815944a1
downloadaur-3f4a911deb12fcefcf98dc7cc40f2b27036cf3c6.tar.gz
Initial commit
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD29
2 files changed, 43 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..110b3c8374f4
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = kwin-effects-unminimize1
+ pkgdesc = KWin effect that animates the unminimizing of windows
+ pkgver = 1.2
+ pkgrel = 1
+ url = https://github.com/zzag/kwin-effects-unminimize1
+ arch = x86_64
+ license = GPL3
+ makedepends = extra-cmake-modules
+ depends = kwin
+ source = kwin-effects-unminimize1-1.2.tar.gz::https://github.com/zzag/kwin-effects-unminimize1/archive/1.2.tar.gz
+ sha256sums = 6f4c76626d72c32586d35be58a46945fe3803cdf2e2e82cf96a14b310b76684a
+
+pkgname = kwin-effects-unminimize1
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6f2eb9563b7b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Vlad Zagorodniy <vladzzag@gmail.com>
+pkgname=kwin-effects-unminimize1
+pkgver=1.2
+pkgrel=1
+pkgdesc="KWin effect that animates the unminimizing of windows"
+arch=('x86_64')
+url="https://github.com/zzag/kwin-effects-unminimize1"
+license=('GPL3')
+depends=(kwin)
+makedepends=(extra-cmake-modules)
+source=(${pkgname}-${pkgver}.tar.gz::https://github.com/zzag/${pkgname}/archive/${pkgver}.tar.gz)
+sha256sums=('6f4c76626d72c32586d35be58a46945fe3803cdf2e2e82cf96a14b310b76684a')
+
+prepare() {
+ mkdir -p build
+}
+
+build() {
+ cd build
+ cmake ../$pkgname-$pkgver \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_INSTALL_LIBDIR=lib
+ make
+}
+
+package() {
+ cd build
+ make DESTDIR="$pkgdir" install
+}