summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorkodehawa2020-11-14 17:06:44 -0300
committerkodehawa2020-11-14 17:06:44 -0300
commit4321181600dc1080696d17260ce854d6b4463bec (patch)
treeed33e5192eff49c1eda544d4cd414552aa1effda
parent4c8bda43d15d1ec55b43413136cd4014635e50b6 (diff)
downloadaur-4321181600dc1080696d17260ce854d6b4463bec.tar.gz
First commit
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD30
2 files changed, 26 insertions, 20 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0886ef7d7bfd..3b52921e3ea8 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,16 @@
-pkgbase = kwin-effects-yet-another-magic-lamp
- pkgdesc = Just Yet Another Magic Lamp effect
- pkgver = 4.1.1
+pkgbase = kwin-effects-yet-another-magic-lamp-git
+ pkgdesc = Just Yet Another Magic Lamp effect. (Git version)
+ pkgver = 4.1.2.r0.g1e38dd1
pkgrel = 1
url = https://github.com/zzag/kwin-effects-yet-another-magic-lamp
arch = x86_64
license = GPL3
makedepends = extra-cmake-modules
- depends = kwin>=5.18.0
- source = kwin-effects-yet-another-magic-lamp-4.1.1.tar.gz::https://github.com/zzag/kwin-effects-yet-another-magic-lamp/archive/4.1.1.tar.gz
- sha256sums = d2425034e299237a94536377a8648817280f9c293add184b295eb169c97e8faa
+ depends = kwin
+ provides = kwin-effects-yet-another-magic-lamp
+ conflicts = kwin-effects-yet-another-magic-lamp
+ source = kwin-effects-yet-another-magic-lamp-git::git+https://github.com/zzag/kwin-effects-yet-another-magic-lamp
+ sha256sums = SKIP
-pkgname = kwin-effects-yet-another-magic-lamp
+pkgname = kwin-effects-yet-another-magic-lamp-git
diff --git a/PKGBUILD b/PKGBUILD
index 692c889a8e85..d2b770abc1c9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,26 +1,30 @@
-# Maintainer: Alejandro Valdes <alejandrovaldes at live dot com>
+# Mantainer: David Rubio Escares (david.alejandro.rubio at gmail dot com)
-pkgname=kwin-effects-yet-another-magic-lamp
-pkgver=4.1.1
+pkgname=kwin-effects-yet-another-magic-lamp-git
+_pkgname=kwin-effects-yet-another-magic-lamp
+pkgver=4.1.2.r0.g1e38dd1
pkgrel=1
-pkgdesc="Just Yet Another Magic Lamp effect"
+pkgdesc="Just Yet Another Magic Lamp effect. (Git version)"
arch=('x86_64')
-url="https://github.com/zzag/$pkgname"
+url="https://github.com/zzag/$_pkgname"
license=('GPL3')
-depends=('kwin>=5.18.0')
makedepends=(extra-cmake-modules)
-source=(${pkgname}-${pkgver}.tar.gz::https://github.com/zzag/${pkgname}/archive/${pkgver}.tar.gz
-)
-sha256sums=('d2425034e299237a94536377a8648817280f9c293add184b295eb169c97e8faa')
+provides=($_pkgname)
+conflicts=($_pkgname)
+depends=(kwin)
+source=($pkgname::git+https://github.com/zzag/$_pkgname)
+sha256sums=('SKIP')
-prepare() {
- mkdir -p build
- cd $srcdir/$pkgname-$pkgver
+pkgver() {
+ cd "$pkgname"
+ git describe --tags --long | sed -r -e 's,^[^0-9]*,,;s,([^-]*-g),r\1,;s,[-_],.,g'
}
build() {
+ mkdir -p build
cd build
- cmake ../$pkgname-$pkgver \
+ cmake ../"$pkgname" \
+ -DCMAKE_BUILD_TYPE=Release \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib
make