summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlejandro Valdes2020-03-28 17:29:05 -0500
committerAlejandro Valdes2020-03-28 17:29:05 -0500
commit4c8bda43d15d1ec55b43413136cd4014635e50b6 (patch)
tree1c1ef1c3f3ade64cc70cf0570728ecd067101056
parent3fb79291be1a1c6e8249e4aa06d0d45fb9672c39 (diff)
downloadaur-4c8bda43d15d1ec55b43413136cd4014635e50b6.tar.gz
Bump to 4.1.1
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD10
-rw-r--r--f411876086099638677d35c4cc023e5d046eff6a.patch60
3 files changed, 9 insertions, 73 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 43f8c6d50dc6..0886ef7d7bfd 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,14 @@
pkgbase = kwin-effects-yet-another-magic-lamp
pkgdesc = Just Yet Another Magic Lamp effect
- pkgver = 4.1
- pkgrel = 2
+ pkgver = 4.1.1
+ pkgrel = 1
url = https://github.com/zzag/kwin-effects-yet-another-magic-lamp
arch = x86_64
license = GPL3
makedepends = extra-cmake-modules
- depends = kwin
- source = kwin-effects-yet-another-magic-lamp-4.1.tar.gz::https://github.com/zzag/kwin-effects-yet-another-magic-lamp/archive/4.1.tar.gz
- source = f411876086099638677d35c4cc023e5d046eff6a.patch
- sha256sums = 12832e90ab52bb32239b8b1f4e3039250b68486f37e82e88c85eba89651fcb99
- sha256sums = 74c7ba20069bb61f0291dd9f40535a943eefc1a69f5e350001bc36951ddb980c
+ depends = kwin>=5.18.0
+ source = kwin-effects-yet-another-magic-lamp-4.1.1.tar.gz::https://github.com/zzag/kwin-effects-yet-another-magic-lamp/archive/4.1.1.tar.gz
+ sha256sums = d2425034e299237a94536377a8648817280f9c293add184b295eb169c97e8faa
pkgname = kwin-effects-yet-another-magic-lamp
diff --git a/PKGBUILD b/PKGBUILD
index 4a69958535e3..692c889a8e85 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
# Maintainer: Alejandro Valdes <alejandrovaldes at live dot com>
pkgname=kwin-effects-yet-another-magic-lamp
-pkgver=4.1
-pkgrel=2
+pkgver=4.1.1
+pkgrel=1
pkgdesc="Just Yet Another Magic Lamp effect"
arch=('x86_64')
url="https://github.com/zzag/$pkgname"
@@ -10,14 +10,12 @@ license=('GPL3')
depends=('kwin>=5.18.0')
makedepends=(extra-cmake-modules)
source=(${pkgname}-${pkgver}.tar.gz::https://github.com/zzag/${pkgname}/archive/${pkgver}.tar.gz
- f411876086099638677d35c4cc023e5d046eff6a.patch)
-sha256sums=('12832e90ab52bb32239b8b1f4e3039250b68486f37e82e88c85eba89651fcb99'
- '74c7ba20069bb61f0291dd9f40535a943eefc1a69f5e350001bc36951ddb980c')
+)
+sha256sums=('d2425034e299237a94536377a8648817280f9c293add184b295eb169c97e8faa')
prepare() {
mkdir -p build
cd $srcdir/$pkgname-$pkgver
- patch --forward --strip=1 --input="${srcdir}/f411876086099638677d35c4cc023e5d046eff6a.patch"
}
build() {
diff --git a/f411876086099638677d35c4cc023e5d046eff6a.patch b/f411876086099638677d35c4cc023e5d046eff6a.patch
deleted file mode 100644
index 96aea46f4bfd..000000000000
--- a/f411876086099638677d35c4cc023e5d046eff6a.patch
+++ /dev/null
@@ -1,60 +0,0 @@
-From f411876086099638677d35c4cc023e5d046eff6a Mon Sep 17 00:00:00 2001
-From: Vlad Zahorodnii <vladzzag@gmail.com>
-Date: Fri, 17 Jan 2020 21:16:41 +0200
-Subject: [PATCH] Fix build with KDE Plasma 5.18 LTS
-
-Fixes #21
----
- src/YetAnotherMagicLampEffect.cc | 10 ++++++++--
- src/YetAnotherMagicLampEffect.h | 5 +++++
- 2 files changed, 13 insertions(+), 2 deletions(-)
-
-diff --git a/src/YetAnotherMagicLampEffect.cc b/src/YetAnotherMagicLampEffect.cc
-index 98dbe59..77e35c1 100644
---- a/src/YetAnotherMagicLampEffect.cc
-+++ b/src/YetAnotherMagicLampEffect.cc
-@@ -168,7 +168,11 @@ void YetAnotherMagicLampEffect::prePaintWindow(KWin::EffectWindow* w, KWin::Wind
- KWin::effects->prePaintWindow(w, data, time);
- }
-
-+#if KWIN_EFFECT_API_VERSION <= KWIN_EFFECT_API_MAKE_VERSION(0, 228)
- void YetAnotherMagicLampEffect::drawWindow(KWin::EffectWindow* w, int mask, QRegion region, KWin::WindowPaintData& data)
-+#else
-+void YetAnotherMagicLampEffect::drawWindow(KWin::EffectWindow* w, int mask, const QRegion& region, KWin::WindowPaintData& data)
-+#endif
- {
- auto modelIt = m_models.constFind(w);
- if (modelIt == m_models.constEnd()) {
-@@ -180,11 +184,13 @@ void YetAnotherMagicLampEffect::drawWindow(KWin::EffectWindow* w, int mask, QReg
- QVector<WindowQuad> quads = m_meshRenderer->makeGrid(w, m_gridResolution);
- (*modelIt).apply(quads);
-
-+ QRegion clipRegion = region;
-+
- if ((*modelIt).needsClip()) {
-- region = (*modelIt).clipRegion();
-+ clipRegion = (*modelIt).clipRegion();
- }
-
-- m_meshRenderer->render(w, quads, texture, region);
-+ m_meshRenderer->render(w, quads, texture, clipRegion);
- }
-
- bool YetAnotherMagicLampEffect::isActive() const
-diff --git a/src/YetAnotherMagicLampEffect.h b/src/YetAnotherMagicLampEffect.h
-index 8d4325a..0455278 100644
---- a/src/YetAnotherMagicLampEffect.h
-+++ b/src/YetAnotherMagicLampEffect.h
-@@ -40,7 +40,12 @@ class YetAnotherMagicLampEffect : public KWin::Effect {
- void postPaintScreen() override;
-
- void prePaintWindow(KWin::EffectWindow* w, KWin::WindowPrePaintData& data, int time) override;
-+
-+#if KWIN_EFFECT_API_VERSION <= KWIN_EFFECT_API_MAKE_VERSION(0, 228)
- void drawWindow(KWin::EffectWindow* w, int mask, QRegion region, KWin::WindowPaintData& data) override;
-+#else
-+ void drawWindow(KWin::EffectWindow* w, int mask, const QRegion& region, KWin::WindowPaintData& data) override;
-+#endif
-
- bool isActive() const override;
- int requestedEffectChainPosition() const override;