summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNarthana Epa2016-07-09 09:44:22 -0400
committerNarthana Epa2016-07-09 09:45:59 -0400
commitb4c2615498537f17cc68cb2e3f5529cb952177a0 (patch)
treeae8274a933909f0b6e228bbd12484ebdf05a0667
parentd4ebd0e34a75e1e69099115ff94fbd408d3b827c (diff)
downloadaur-b4c2615498537f17cc68cb2e3f5529cb952177a0.tar.gz
5.7.0
-rw-r--r--.SRCINFO18
-rw-r--r--.gitignore5
-rw-r--r--PKGBUILD23
3 files changed, 29 insertions, 17 deletions
diff --git a/.SRCINFO b/.SRCINFO
index efb85514586e..b72e5c5819f0 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = kwin-presentwindows-close
pkgdesc = KDE Window manager, reverting the removal of the close action in present windows
- pkgver = 5.6.4
+ pkgver = 5.7.0
pkgrel = 1
url = https://www.kde.org/workspaces/plasmadesktop/
arch = i686
@@ -10,25 +10,27 @@ pkgbase = kwin-presentwindows-close
makedepends = extra-cmake-modules
makedepends = qt5-tools
makedepends = kdoctools
- makedepends = libinput
makedepends = python
depends = qt5-multimedia
depends = kscreenlocker
depends = knewstuff
depends = xcb-util-cursor
depends = hicolor-icon-theme
- depends = kdecoration
- depends = kinit
depends = plasma-framework
depends = kcmutils
- optdepends = libinput: for kwin-wayland
+ depends = breeze
+ optdepends = qt5-virtualkeyboard: virtual keyboard support for kwin-wayland
provides = kwin
conflicts = kdebase-workspace
conflicts = kwin
- source = http://download.kde.org/stable/plasma/5.6.4/kwin-5.6.4.tar.xz
+ source = http://download.kde.org/stable/plasma/5.7.0/kwin-5.7.0.tar.xz
+ source = http://download.kde.org/stable/plasma/5.7.0/kwin-5.7.0.tar.xz.sig
source = presentwindows-close.patch
- md5sums = 6afbe6f1659cac2e186dcce9f92f51de
- md5sums = 84538b8d5331a3f3f59cc31e393025d2
+ validpgpkeys = 13C16D03EDE728514473AA73A506E6D4DD4D5088
+ validpgpkeys = D07BD8662C56CB291B316EB2F5675605C74E02CF
+ sha256sums = f57ec7fec961f5e490e0bf0e3e903e0656d12eccbbbbf6a23c84a8dd4866edd6
+ sha256sums = SKIP
+ sha256sums = a42e050f873632240595026b0f0f98ce4e109dd36a7768ba6b361d1b4854aefb
pkgname = kwin-presentwindows-close
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..7334925ab911
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+*
+!.gitignore
+!.SRCINFO
+!PKGBUILD
+!*.patch
diff --git a/PKGBUILD b/PKGBUILD
index a17dffeee5a1..d8d2cf8ae421 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,21 +4,26 @@
_pkgorigname=kwin
pkgname=kwin-presentwindows-close
-pkgver=5.6.4
+pkgver=5.7.0
pkgrel=1
pkgdesc='KDE Window manager, reverting the removal of the close action in present windows'
arch=('i686' 'x86_64')
url='https://www.kde.org/workspaces/plasmadesktop/'
license=('LGPL')
-depends=('qt5-multimedia' 'kscreenlocker' 'knewstuff' 'xcb-util-cursor' 'hicolor-icon-theme' 'kdecoration' 'kinit' 'plasma-framework' 'kcmutils')
-makedepends=('extra-cmake-modules' 'qt5-tools' 'kdoctools' 'libinput' 'python')
-optdepends=('libinput: for kwin-wayland')
+depends=('qt5-multimedia' 'kscreenlocker' 'knewstuff' 'xcb-util-cursor' 'hicolor-icon-theme'
+ 'plasma-framework' 'kcmutils' 'breeze')
+makedepends=('extra-cmake-modules' 'qt5-tools' 'kdoctools' 'python')
+optdepends=('qt5-virtualkeyboard: virtual keyboard support for kwin-wayland')
groups=('plasma')
conflicts=('kdebase-workspace' 'kwin')
provides=('kwin')
-source=("http://download.kde.org/stable/plasma/${pkgver}/${_pkgorigname}-${pkgver}.tar.xz" presentwindows-close.patch)
-md5sums=('6afbe6f1659cac2e186dcce9f92f51de'
- '84538b8d5331a3f3f59cc31e393025d2')
+source=("http://download.kde.org/stable/plasma/${pkgver}/${_pkgorigname}-${pkgver}.tar.xz"{,.sig}
+ "presentwindows-close.patch")
+sha256sums=('f57ec7fec961f5e490e0bf0e3e903e0656d12eccbbbbf6a23c84a8dd4866edd6'
+ 'SKIP'
+ 'a42e050f873632240595026b0f0f98ce4e109dd36a7768ba6b361d1b4854aefb')
+validpgpkeys=('13C16D03EDE728514473AA73A506E6D4DD4D5088' # Jonathan Riddell
+ 'D07BD8662C56CB291B316EB2F5675605C74E02CF') # David Edmundson
prepare() {
mkdir -p build
@@ -29,7 +34,7 @@ prepare() {
build() {
cd build
- cmake ../${_pkgorigname}-${pkgver} \
+ cmake ../$_pkgorigname-$pkgver \
-DCMAKE_BUILD_TYPE=Release \
-DCMAKE_INSTALL_PREFIX=/usr \
-DKDE_INSTALL_LIBDIR=lib \
@@ -40,5 +45,5 @@ build() {
package() {
cd build
- make DESTDIR="${pkgdir}" install
+ make DESTDIR="$pkgdir" install
}