summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNarthana Epa2016-05-27 18:16:18 -0400
committerNarthana Epa2016-05-27 18:16:18 -0400
commitd4ebd0e34a75e1e69099115ff94fbd408d3b827c (patch)
tree79024d27b61c915189dd7d940733446cb9a3422d
downloadaur-d4ebd0e34a75e1e69099115ff94fbd408d3b827c.tar.gz
5.6.4-1
-rw-r--r--.SRCINFO34
-rw-r--r--PKGBUILD44
-rw-r--r--presentwindows-close.patch83
3 files changed, 161 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..efb85514586e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,34 @@
+pkgbase = kwin-presentwindows-close
+ pkgdesc = KDE Window manager, reverting the removal of the close action in present windows
+ pkgver = 5.6.4
+ pkgrel = 1
+ url = https://www.kde.org/workspaces/plasmadesktop/
+ arch = i686
+ arch = x86_64
+ groups = plasma
+ license = LGPL
+ makedepends = extra-cmake-modules
+ makedepends = qt5-tools
+ makedepends = kdoctools
+ makedepends = libinput
+ makedepends = python
+ depends = qt5-multimedia
+ depends = kscreenlocker
+ depends = knewstuff
+ depends = xcb-util-cursor
+ depends = hicolor-icon-theme
+ depends = kdecoration
+ depends = kinit
+ depends = plasma-framework
+ depends = kcmutils
+ optdepends = libinput: for kwin-wayland
+ provides = kwin
+ conflicts = kdebase-workspace
+ conflicts = kwin
+ source = http://download.kde.org/stable/plasma/5.6.4/kwin-5.6.4.tar.xz
+ source = presentwindows-close.patch
+ md5sums = 6afbe6f1659cac2e186dcce9f92f51de
+ md5sums = 84538b8d5331a3f3f59cc31e393025d2
+
+pkgname = kwin-presentwindows-close
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a17dffeee5a1
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,44 @@
+# $Id$
+# Maintainer: Felix Yan <felixonmars@archlinux.org>
+# Contributor: Andrea Scarpino <andrea@archlinux.org>
+
+_pkgorigname=kwin
+pkgname=kwin-presentwindows-close
+pkgver=5.6.4
+pkgrel=1
+pkgdesc='KDE Window manager, reverting the removal of the close action in present windows'
+arch=('i686' 'x86_64')
+url='https://www.kde.org/workspaces/plasmadesktop/'
+license=('LGPL')
+depends=('qt5-multimedia' 'kscreenlocker' 'knewstuff' 'xcb-util-cursor' 'hicolor-icon-theme' 'kdecoration' 'kinit' 'plasma-framework' 'kcmutils')
+makedepends=('extra-cmake-modules' 'qt5-tools' 'kdoctools' 'libinput' 'python')
+optdepends=('libinput: for kwin-wayland')
+groups=('plasma')
+conflicts=('kdebase-workspace' 'kwin')
+provides=('kwin')
+source=("http://download.kde.org/stable/plasma/${pkgver}/${_pkgorigname}-${pkgver}.tar.xz" presentwindows-close.patch)
+md5sums=('6afbe6f1659cac2e186dcce9f92f51de'
+ '84538b8d5331a3f3f59cc31e393025d2')
+
+prepare() {
+ mkdir -p build
+
+ cd $_pkgorigname-$pkgver
+ patch -p1 -R < ../presentwindows-close.patch
+}
+
+build() {
+ cd build
+ cmake ../${_pkgorigname}-${pkgver} \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DKDE_INSTALL_LIBDIR=lib \
+ -DKDE_INSTALL_LIBEXECDIR=lib \
+ -DBUILD_TESTING=OFF
+ make
+}
+
+package() {
+ cd build
+ make DESTDIR="${pkgdir}" install
+}
diff --git a/presentwindows-close.patch b/presentwindows-close.patch
new file mode 100644
index 000000000000..de0b67c55960
--- /dev/null
+++ b/presentwindows-close.patch
@@ -0,0 +1,83 @@
+diff --git a/effects/presentwindows/presentwindows.h b/effects/presentwindows/presentwindows.h
+index 7e09b02..eecf70a 100644
+--- a/effects/presentwindows/presentwindows.h
++++ b/effects/presentwindows/presentwindows.h
+@@ -137,8 +137,7 @@ public:
+ WindowExitAction = 2, // Deactivates the effect without activating new window
+ WindowToCurrentDesktopAction = 3, // Brings window to current desktop
+ WindowToAllDesktopsAction = 4, // Brings window to all desktops
+- WindowMinimizeAction = 5, // Minimize the window
+- WindowCloseAction = 6 // Closes the window
++ WindowMinimizeAction = 5 // Minimize the window
+ };
+ enum DesktopMouseAction {
+ DesktopNoAction = 0, // nothing
+commit 76c70a3c4b8ecaf44c2eb46f19a0c64048acc833
+Author: Martin Gräßlin <mgraesslin@kde.org>
+Date: Fri Feb 8 11:37:58 2013 +0100
+
+ Remove close window mouse action from Present Windows effect
+
+ This feature has been superseded by the close window button and as it
+ is a rather destructive action it makes sense to remove it.
+
+ Sorry to everyone who used it.
+
+ CCBUG: 314393
+
+diff --git a/effects/presentwindows/presentwindows.cpp b/effects/presentwindows/presentwindows.cpp
+index 9cfd599..ace76bc 100755
+--- a/effects/presentwindows/presentwindows.cpp
++++ b/effects/presentwindows/presentwindows.cpp
+@@ -670,11 +670,6 @@ void PresentWindowsEffect::mouseActionWindow(WindowMouseAction& action)
+ m_highlightedWindow->minimize();
+ }
+ break;
+- case WindowCloseAction:
+- if (m_highlightedWindow) {
+- m_highlightedWindow->closeWindow();
+- }
+- break;
+ default:
+ break;
+ }
+diff --git a/effects/presentwindows/presentwindows_config.ui b/effects/presentwindows/presentwindows_config.ui
+index 336efec..cb1ebba 100644
+--- a/effects/presentwindows/presentwindows_config.ui
++++ b/effects/presentwindows/presentwindows_config.ui
+@@ -161,11 +161,6 @@
+ <string>(Un-)Minimize window</string>
+ </property>
+ </item>
+- <item>
+- <property name="text">
+- <string>Close window</string>
+- </property>
+- </item>
+ </widget>
+ </item>
+ <item row="1" column="0">
+@@ -210,11 +205,6 @@
+ <string>(Un-)Minimize window</string>
+ </property>
+ </item>
+- <item>
+- <property name="text">
+- <string>Close window</string>
+- </property>
+- </item>
+ </widget>
+ </item>
+ <item row="2" column="0">
+@@ -259,11 +249,6 @@
+ <string>(Un-)Minimize window</string>
+ </property>
+ </item>
+- <item>
+- <property name="text">
+- <string>Close window</string>
+- </property>
+- </item>
+ </widget>
+ </item>
+ </layout>