summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorhorstderheld2020-06-26 14:56:50 +0200
committerhorstderheld2020-06-26 14:56:50 +0200
commit59ec49aa07037ccd2a283594db72cef72402ce2f (patch)
tree8bb5ff1f9ced88ad63dd9b466189c190e52f7e15
downloadaur-59ec49aa07037ccd2a283594db72cef72402ce2f.tar.gz
initial commit
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD17
2 files changed, 31 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..976b81f95e08
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = kwin-scripts-maxmize-to-new-desktop
+ pkgdesc = KWin script that moves fullscreened window to a new virtual desktop, emulating macOS like maximize to new desktop.
+ pkgver = 0.2.2
+ pkgrel = 1
+ url = https://store.kde.org/p/1171196/
+ arch = any
+ license = BSD 2-Clause
+ depends = kdesignerplugin
+ depends = kwin
+ source = https://github.com/Aetf/kwin-maxmize-to-new-desktop/archive/v0.2.2.tar.gz
+ sha512sums = 9220420878a2e70012786af62c00a791b0fddb38190f2b9eafc30ce1a908652bdf257eec392e16ed0263cf39a686279d3dcd94c8bbfa1c67ea105ac9fa494eab
+
+pkgname = kwin-scripts-maxmize-to-new-desktop
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5b3615b0cdbf
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,17 @@
+pkgname=kwin-scripts-maxmize-to-new-desktop
+_pkgname=kwin-maxmize-to-new-desktop
+pkgver=0.2.2
+pkgrel=1
+pkgdesc="KWin script that moves fullscreened window to a new virtual desktop, emulating macOS like maximize to new desktop."
+arch=('any')
+url="https://store.kde.org/p/1171196/"
+license=('BSD 2-Clause')
+depends=('kdesignerplugin' 'kwin')
+source=("https://github.com/Aetf/${_pkgname}/archive/v${pkgver}.tar.gz")
+sha512sums=('9220420878a2e70012786af62c00a791b0fddb38190f2b9eafc30ce1a908652bdf257eec392e16ed0263cf39a686279d3dcd94c8bbfa1c67ea105ac9fa494eab')
+
+package() {
+ install -d "${pkgdir}/usr/share/kwin/scripts/${_pkgname}"
+ cp -r "${srcdir}"/${_pkgname}-${pkgver}/{contents,doc,metadata.desktop} "${pkgdir}/usr/share/kwin/scripts/${_pkgname}"
+ install -Dm644 "${srcdir}"/${_pkgname}-${pkgver}/metadata.desktop "${pkgdir}/usr/share/kservices5/${_pkgname}.desktop"
+}